Bug 1684767 - Errors in upgrading from F29 to F30 (python-flake8)
Summary: Errors in upgrading from F29 to F30 (python-flake8)
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-obsolete-packages
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-02 09:51 UTC by Mattia Verga
Modified: 2019-03-04 22:15 UTC (History)
5 users (show)

Fixed In Version: fedora-obsolete-packages-30-30, python-flake8-3.7.7-1.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-04 22:15:41 UTC


Attachments (Terms of Use)

Description Mattia Verga 2019-03-02 09:51:27 UTC
Python-flake8 gives errors while upgrading the system from F29 to F30 due to python2 subpackage removal:

Problema 3: package python2-flake8-3.6.0-2.fc30.noarch requires python2.7dist(pycodestyle) < 2.5.0, but none of the providers can be installed
  - problem with installed package python2-flake8-3.5.0-6.fc29.noarch
  - python2-pycodestyle-2.4.0-3.fc29.noarch does not belong to a distupgrade repository
  - python2-flake8-3.5.0-6.fc29.noarch does not belong to a distupgrade repository

 Problema 4: package python3-flake8-3.6.0-2.fc30.noarch requires python3.7dist(pycodestyle) < 2.5.0, but none of the providers can be installed
  - problem with installed package python3-flake8-3.5.0-6.fc29.noarch
  - python3-pycodestyle-2.4.0-3.fc29.noarch does not belong to a distupgrade repository
  - python3-flake8-3.5.0-6.fc29.noarch does not belong to a distupgrade repository

See also https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/D4ZBMUAOS63DFEKS4J35EQP5P7VVTPMM/#AZ45YHLPEP6E4RASZBTF4L5KJDYF2GEQ

Comment 1 Miro Hrončok 2019-03-02 10:01:22 UTC
This has been fixed by python3-flake8 3.7.7. python2-flake8 was removed and will be obsoleted by fedora-obsolete-packages.


Note You need to log in before you can comment on or make changes to this bug.