Bug 1684777 - gNFS crashed when processing "gluster v profile [vol] info nfs"
Summary: gNFS crashed when processing "gluster v profile [vol] info nfs"
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: nfs
Version: 6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1677559
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-02 11:58 UTC by Shyamsundar
Modified: 2019-03-25 16:33 UTC (History)
2 users (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1677559
Environment:
Last Closed: 2019-03-04 03:38:38 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 22235 None Merged glusterfsd: Do not process PROFILE_NFS_INFO if graph is not ready 2019-03-04 03:38:37 UTC

Description Shyamsundar 2019-03-02 11:58:05 UTC
+++ This bug was initially created as a clone of Bug #1677559 +++

Description of problem:
when processing "gluster v profile [vol] info nfs" after gnfs start, gnfs will crash.

dump trace info:
/lib64/libglusterfs.so.0(_gf_msg_backtrace_nomem+0xc2)[0x7fcf5cb6a872]
/lib64/libglusterfs.so.0(gf_print_trace+0x324)[0x7fcf5cb743a4]
/lib64/libc.so.6(+0x35670)[0x7fcf5b1d5670]
/usr/sbin/glusterfs(glusterfs_handle_nfs_profile+0x114)[0x7fcf5d066474]
/lib64/libglusterfs.so.0(synctask_wrap+0x12)[0x7fcf5cba1502]
/lib64/libc.so.6(+0x47110)[0x7fcf5b1e7110]

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.create dht volume naming dht_vol,and start the vol
2.start volume profile
3.kill gnfs process
4.process cli "service glusterd restart;gluster volume profile dht_vol info nfs"

Comment 1 Worker Ant 2019-03-02 11:59:33 UTC
REVIEW: https://review.gluster.org/22235 (glusterfsd: Do not process PROFILE_NFS_INFO if graph is not ready) posted (#2) for review on release-6 by Shyamsundar Ranganathan

Comment 2 Worker Ant 2019-03-04 03:38:38 UTC
REVIEW: https://review.gluster.org/22235 (glusterfsd: Do not process PROFILE_NFS_INFO if graph is not ready) merged (#3) on release-6 by Amar Tumballi

Comment 3 Shyamsundar 2019-03-25 16:33:26 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.