Bug 1684818 - dist-upgrade to f30 fails - dependency problems
Summary: dist-upgrade to f30 fails - dependency problems
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ceph
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Boris Ranto
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1684250
TreeView+ depends on / blocked
 
Reported: 2019-03-02 18:24 UTC by Tomasz Torcz
Modified: 2019-03-07 12:47 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-07 12:45:08 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 38611 None None None 2019-03-07 12:47:26 UTC

Description Tomasz Torcz 2019-03-02 18:24:45 UTC
Description of problem:
With respect to https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/D4ZBMUAOS63DFEKS4J35EQP5P7VVTPMM/

Upgrading to Fedora 30 fails:

 Problem 2: package python-cephfs-1:12.2.11-1.fc29.x86_64 requires libcephfs2 = 1:12.2.11-1.fc29, but none of the providers can be installed
  - libcephfs2-1:12.2.11-1.fc29.x86_64 does not belong to a distupgrade repository
  - problem with installed package python-cephfs-1:12.2.11-1.fc29.x86_64
 
 Problem 3: package python-rados-1:12.2.11-1.fc29.x86_64 requires librados2 = 1:12.2.11-1.fc29, but none of the providers can be installed
  - librados2-1:12.2.11-1.fc29.x86_64 does not belong to a distupgrade repository
  - problem with installed package python-rados-1:12.2.11-1.fc29.x86_64
 
 Problem 4: package python-rbd-1:12.2.11-1.fc29.x86_64 requires librbd1 = 1:12.2.11-1.fc29, but none of the providers can be installed
  - librbd1-1:12.2.11-1.fc29.x86_64 does not belong to a distupgrade repository
  - problem with installed package python-rbd-1:12.2.11-1.fc29.x86_64
 
 Problem 5: package python-rgw-1:12.2.11-1.fc29.x86_64 requires librgw2 = 1:12.2.11-1.fc29, but none of the providers can be installed
  - librgw2-1:12.2.11-1.fc29.x86_64 does not belong to a distupgrade repository
  - problem with installed package python-rgw-1:12.2.11-1.fc29.x86_64
P
roblem 14: package ceph-mgr-2:14.0.1-4.fc30.x86_64 requires python3-pecan, but none of the providers can be installed
  - package python3-pecan-1.3.2-6.fc30.noarch conflicts with python2-pecan < 1.3.2-5 provided by python2-pecan-1.3.2-4.fc29.noarch
  - cannot install the best update candidate for package ceph-mgr-1:12.2.11-1.fc29.x86_64
  - problem with installed package python2-pecan-1.3.2-4.fc29.noarch

 Problem 15: package python-cephfs-1:12.2.11-1.fc29.x86_64 requires libcephfs2 = 1:12.2.11-1.fc29, but none of the providers can be installed
  - cannot install both libcephfs2-2:14.0.1-4.fc30.x86_64 and libcephfs2-1:12.2.11-1.fc29.x86_64
  - package python-ceph-compat-1:12.2.11-1.fc29.x86_64 requires python-cephfs = 1:12.2.11-1.fc29, but none of the providers can be installed
  - cannot install the best update candidate for package libcephfs2-1:12.2.11-1.fc29.x86_64
  - problem with installed package python-ceph-compat-1:12.2.11-1.fc29.x86_64

Comment 1 Randy Barlow 2019-03-06 15:07:49 UTC
I am unable to build Bodhi in Fedora 30 due to not being able to install librados:

Problem: package libguestfs-1:1.40.2-2.fc30.ppc64le requires libvirt-daemon-qemu >= 0.10.2-3, but none of the providers can be installed
 - package libvirt-daemon-qemu-5.1.0-1.fc30.ppc64le requires libvirt-daemon-driver-storage = 5.1.0-1.fc30, but none of the providers can be installed
 - package libguestfs-tools-c-1:1.40.2-2.fc30.ppc64le requires libguestfs.so.0()(64bit), but none of the providers can be installed
 - package libguestfs-tools-c-1:1.40.2-2.fc30.ppc64le requires libguestfs(ppc-64) = 1:1.40.2-2.fc30, but none of the providers can be installed
 - package libvirt-daemon-driver-storage-5.1.0-1.fc30.ppc64le requires libvirt-daemon-driver-storage-rbd = 5.1.0-1.fc30, but none of the providers can be installed
 - package pungi-4.1.33-6.fc30.noarch requires libguestfs-tools-c, but none of the providers can be installed
 - package libvirt-daemon-driver-storage-rbd-5.1.0-1.fc30.ppc64le requires librados.so.2()(64bit), but none of the providers can be installed
 - conflicting requests
 - nothing provides libcrc32.so()(64bit) needed by librados2-1:14.1.0-1.fc30.ppc64le

Comment 2 Kaleb KEITHLEY 2019-03-06 20:08:53 UTC
(In reply to Randy Barlow from comment #1)
> I am unable to build Bodhi in Fedora 30 due to not being able to install
> librados:
> ...
>  - package libvirt-daemon-driver-storage-rbd-5.1.0-1.fc30.ppc64le requires
> librados.so.2()(64bit), but none of the providers can be installed
>  - conflicting requests
>  - nothing provides libcrc32.so()(64bit) needed by
> librados2-1:14.1.0-1.fc30.ppc64le

This should be addressed in ceph-14.1.0-2, which is building now.

Comment 3 Kaleb KEITHLEY 2019-03-07 12:45:08 UTC
Fixed in ceph-14.1.0-2


Note You need to log in before you can comment on or make changes to this bug.