Bug 1684819 - upgrading to F30 fails - dependency problems: python2-ipaclient
Summary: upgrading to F30 fails - dependency problems: python2-ipaclient
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-obsolete-packages
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-02 18:28 UTC by Tomasz Torcz
Modified: 2019-10-30 18:00 UTC (History)
12 users (show)

Fixed In Version: fedora-obsolete-packages-30-30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-04 22:15:18 UTC


Attachments (Terms of Use)

Description Tomasz Torcz 2019-03-02 18:28:14 UTC
Description of problem:
With respect to https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/D4ZBMUAOS63DFEKS4J35EQP5P7VVTPMM/
Upgrading to fedora 30 fails with:

Problem 6: package python2-ipaclient-4.7.2-1.1.fc29.noarch requires freeipa-client-common = 4.7.2-1.1.fc29, but none of the providers can be installed
  - freeipa-client-common-4.7.2-1.1.fc29.noarch does not belong to a distupgrade repository
  - problem with installed package python2-ipaclient-4.7.2-1.1.fc29.noarch


 Problem 7: package python2-ipalib-4.7.2-1.1.fc29.noarch requires freeipa-common = 4.7.2-1.1.fc29, but none of the providers can be installed
  - freeipa-common-4.7.2-1.1.fc29.noarch does not belong to a distupgrade repository
  - problem with installed package python2-ipalib-4.7.2-1.1.fc29.noarch


 Problem 8: package python2-libipa_hbac-2.0.0-5.fc29.x86_64 requires libipa_hbac = 2.0.0-5.fc29, but none of the providers can be installed
  - libipa_hbac-2.0.0-5.fc29.x86_64 does not belong to a distupgrade repository
  - problem with installed package python2-libipa_hbac-2.0.0-5.fc29.x86_64

Comment 1 Alexander Bokovoy 2019-03-02 19:08:21 UTC
All these package names are already in fedora-package-obsoletes for F30.

Comment 2 Alexander Bokovoy 2019-03-03 11:00:38 UTC
Same problem like with sssd python2 packages -- the affected package names are in fedora-obsolete-packages already and uprade still fails.

Comment 3 Miro Hrončok 2019-03-03 11:46:58 UTC
Because the version in F29 is higher than the obsoleted version.

Comment 4 Adam Williamson 2019-10-30 18:00:30 UTC
Note, this happened again (f29 versions exceeded the version statements in fedora-obsolete-packages). I just fixed it again and will send out updates for f30 and f31.


Note You need to log in before you can comment on or make changes to this bug.