Bug 1684820 - upgrading to F30 fails - dependency problems with python2-libsss_nss_idmap
Summary: upgrading to F30 fails - dependency problems with python2-libsss_nss_idmap
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-obsolete-packages
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-02 18:29 UTC by Tomasz Torcz
Modified: 2019-03-04 22:14 UTC (History)
10 users (show)

Fixed In Version: fedora-obsolete-packages-30-30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-04 22:14:56 UTC


Attachments (Terms of Use)

Description Tomasz Torcz 2019-03-02 18:29:33 UTC
Description of problem:
With respect to https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/D4ZBMUAOS63DFEKS4J35EQP5P7VVTPMM/
Ugrading to fedora 30 fails with


 Problem 9: package python2-libsss_nss_idmap-2.0.0-5.fc29.x86_64 requires libsss_nss_idmap = 2.0.0-5.fc29, but none of the providers can be installed
  - libsss_nss_idmap-2.0.0-5.fc29.x86_64 does not belong to a distupgrade repository
  - problem with installed package python2-libsss_nss_idmap-2.0.0-5.fc29.x86_64

Comment 1 Alexander Bokovoy 2019-03-02 18:34:15 UTC
python2-libsss_nss_idmap needs to be added to fedora-obsolete-packages: https://src.fedoraproject.org/rpms/fedora-obsolete-packages

Comment 2 Alexander Bokovoy 2019-03-02 19:06:14 UTC
Hm. It *is* already in there. SSSD package obsoletes were added quite some time ago.

Comment 3 Lukas Slebodnik 2019-03-02 21:03:57 UTC
(In reply to Alexander Bokovoy from comment #2)
> Hm. It *is* already in there. SSSD package obsoletes were added quite some
> time ago.

But obsolete there are not sufficient

sh-5.0$ rpm -q fedora-obsolete-packages
fedora-obsolete-packages-30-25.noarch
sh-5.0$ rpm -q --obsoletes fedora-obsolete-packages | grep sss
python2-libsss_nss_idmap < 2.0.0-5
python2-sss < 2.0.0-6
python2-sss-murmur < 2.0.0-6


python2-libsss_nss_idmap-2.0.0-5.fc29.x86_64 is not obsoleted by fedora-obsolete-packages-30-25.noarch

And version&release will be bumped many times in f29 cause f29 is far from EOL.

Comment 4 Lukas Slebodnik 2019-03-02 21:05:31 UTC
Adding needinfo to people who did python2 removal in BZ1629737

Comment 5 Miro Hrončok 2019-03-03 09:54:28 UTC
When you update sssd in stable release, you need to bump the obsolete version-release in fedora-obsolete-packages.

I'll set it to 2.0.0-20 for now so you don't have to do it every day, but note that if you ever go to e.g. 2.0.1 you'll need to bump it. Also, if you ever need to readd python2-libsss_nss_idmap etc. to newer Fedora, you need to make it at least 2.0.0-21.

Comment 6 Lukas Slebodnik 2019-03-04 09:38:34 UTC
(In reply to Miro Hrončok from comment #5)
> When you update sssd in stable release, you need to bump the obsolete
> version-release in fedora-obsolete-packages.
> 
> I'll set it to 2.0.0-20 for now so you don't have to do it every day, but
> note that if you ever go to e.g. 2.0.1 you'll need to bump it. Also, if you
> ever need to readd python2-libsss_nss_idmap etc. to newer Fedora, you need
> to make it at least 2.0.0-21.

There is already sssd 2.1.0 in upstream Which should land in fedora soon (At least it was promised)
https://pagure.io/SSSD/sssd/releases

I would recommend to change obsolete to 2.1.0-20

Comment 7 Miro Hrončok 2019-03-04 21:45:59 UTC
Adding.

python2-libsss_nss_idmap < 2.1.0-20
python2-sss < 2.1.0-20
python2-sss-murmur < 2.1.0-20

Comment 8 Miro Hrončok 2019-03-04 22:05:06 UTC
And

python2-libipa_hbac < 2.1.0-20


Note You need to log in before you can comment on or make changes to this bug.