Bug 1684837 - libprelude-5.0.0-1.fc29 provides libprelude.so.28, but suricata-4.0.6-1.fc29 requires libprelude.so.23
Summary: libprelude-5.0.0-1.fc29 provides libprelude.so.28, but suricata-4.0.6-1.fc29 ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: libprelude
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Thomas Andrejak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-02 23:32 UTC by Matt Fagnani
Modified: 2019-07-14 12:58 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-14 12:58:32 UTC
Type: Bug


Attachments (Terms of Use)

Description Matt Fagnani 2019-03-02 23:32:02 UTC
Description of problem:

libprelude-5.0.0-1.fc29 provides libprelude.so.28, but suricata-4.0.6-1.fc29 requires libprelude.so.23 according to the following dnf error I got

Problem: package suricata-4.0.6-1.fc29.i686 requires libprelude.so.23, but none of the providers can be installed - cannot install both libprelude-5.0.0-1.fc29.i686 and libprelude-4.1.0-6.fc29.i686 - cannot install both libprelude-4.1.0-6.fc29.i686 and libprelude-5.0.0-1.fc29.i686 - cannot install the best update candidate for package suricata-4.0.6-1.fc29.i686 - cannot install the best update candidate for package libprelude-4.1.0-6.fc29.i686



Version-Release number of selected component (if applicable):
libprelude-5.0.0-1.fc29
suricata-4.0.6-1.fc29

How reproducible:
2 of 2 times

Steps to Reproduce:
1. sudo dnf upgrade --refresh (in F29 with updates-testing enabled and suricata and libprelude installed)
2.
3.

Actual results:
The dnf error above occurred and the libprelude update was skipped.

Expected results:
The update to libprelude-5.0.0-1.fc29 completes without errors.

Additional info:

A buildroot override for libprelude-5.0.0-1 could be done. suricata might need to be rebuilt to use libprelude.so.28 from libprelude-5.0.0-1 and added to https://bodhi.fedoraproject.org/updates/FEDORA-2019-b930416244 

I'll try to cc suricata's maintainer Steve Grubb. Could Steve or another of suricata's maintainers rebuild suricata? Thanks.

Comment 1 Jason Taylor 2019-03-03 13:40:12 UTC
I am not sure introducing a soname bump so late in a release cycle (fedora 29) is a good idea. 

It looks like the reason the version was bumped was to fix the FTBFS for f30[0][1]. If that's the case I would recommend just pushing/building libprelude 5.0.0 for f30/rawhide and leaving f29 at the libprelude 4.x release.

[0] https://koji.fedoraproject.org/koji/buildinfo?buildID=1217708

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1629893

thoughts?

Comment 2 Jason Taylor 2019-03-03 13:45:22 UTC
As a side note, I commented on the libprelude 5.0.0 build with a negative karma so the build doesn't get automatically pushed and break the fedora 29 suricata release.

JT

Comment 3 Matt Fagnani 2019-03-03 19:58:12 UTC
Might Thomas and prelude's other maintainers intend to update to prelude-*-5.0.0 in F29? Do prelude-*-5.0.0 require libprelude-5.0.0? Are there other fixes in the 5.0.0 branch? Are there incompatible API/ABI changes in libprelude-5.0.0 that might affect the building of suricata? Jason, if you or Steve see problems when building suricata with libprelude-5.0.0 for F30/rawhide, then rebuilding suricata for F29 might not be needed. Thanks.

Comment 4 Thomas Andrejak 2019-03-03 22:56:20 UTC
Hello

I intend to update the whole prelude packages to 5.0 in f29 if it's possible.

The API/ABI changed but with retrocompatiblity. Unfortunately, upstream bump the soname ...

If it's too difficult to rebuild suricata, I will cancel prelude bump version in F29.

Regards

Comment 5 Steve Grubb 2019-03-04 22:19:14 UTC
Normally big changes like that are done in rawhide instead of a shipped distro. There is time to get this into F30 since its still in development mode. Also, there is some policy that soname bumps should be announced on fedora-devel. How much runtime has this version of libprelude spent in rawhide?

Comment 6 Thomas Andrejak 2019-03-04 23:36:48 UTC
Hello

Too few runtime in rawhide. OK, so no prelude 5.0 in f29. No problem.

Regards


Note You need to log in before you can comment on or make changes to this bug.