Bug 168499 - EXT3 filesystem writes are half slower than reads during backup and restore
EXT3 filesystem writes are half slower than reads during backup and restore
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-16 14:08 EDT by Ashish Tripathi
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 14:54:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Result of sysreport (7.69 MB, patch)
2005-09-20 10:49 EDT, Ashish Tripathi
no flags Details | Diff

  None (edit)
Description Ashish Tripathi 2005-09-16 14:08:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
Hi,
   I am using Redhat AS 3.0 (2.4.21-20.ELsmp) with EXT3 filesystems. The disks reside on a Fibre connected HP SAN storage. I am using HP Data Protector 5.0 for backups/restores.During backups, the average read speed is around 28 MB/s but during restores the write speeds drops down to 12-14MB/s.I have tried this on RAID 0+1 and RAID 5 storage but resutlts were the same.
    Please help.
Thanks.
Ashish

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Restore to RAID 0+1
2.Restore to RAID5
3.
  

Actual Results:  Results were the same. Write speed was around 12-14 MB/s MB/s.

Expected Results:  Write speed should have been atleast 20-25 MB/s.

Additional info:
Comment 1 Tom Coughlan 2005-09-16 17:59:48 EDT
What is the HBA and driver? what model storage? any error messages in
/var/log/messages?

The easiest way to proivide the needed info is to run sysreport and post the
results. 

To start with, it would be helpful to get some raw I/O performance numbers,
excluding the filesystem, etc. If you have a partition on the storage that you
can scratch, then run a simple test like "badblocks" and compare with "badblocks
-w". Use "vmstat 1" to monitor the performance. Post the reasults. 
Comment 2 Ashish Tripathi 2005-09-19 10:03:29 EDT
Hi, 
   Please find the results of "sysreport" attached. Do I really need to run 
tests on raw device because the issue here is the write performance on the 
same filesystem while read performance is decent. 
Thanks.
Ashish
Comment 3 Ashish Tripathi 2005-09-19 10:05:50 EDT
Please let me know how can I attach the output file of sysreport as it is 
bzipped tar archive and bugzilla site is not allowing to attach it.
Thanks.
Comment 4 Ashish Tripathi 2005-09-20 10:49:18 EDT
Created attachment 119027 [details]
Result of sysreport

I have attached the result of sysreport as requested.
Thanks.
Comment 5 Ernie Petrides 2005-10-03 21:56:12 EDT
Reverting to ASSIGNED state.
Comment 6 RHEL Product and Program Management 2007-10-19 14:54:12 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.