Bug 16853 - minicom -C filename creates files with uucp as group owner
Summary: minicom -C filename creates files with uucp as group owner
Status: CLOSED DUPLICATE of bug 16738
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: minicom   
(Show other bugs)
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-24 10:13 UTC by Jarno Huuskonen
Modified: 2014-03-17 02:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-24 10:14:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ugly patch to set egid to real_gid before opening -C file (1.92 KB, patch)
2000-08-24 10:14 UTC, Jarno Huuskonen
no flags Details | Diff

Description Jarno Huuskonen 2000-08-24 10:13:05 UTC
This was already reported on bugtraq, but here it goes again.

If user runs minicom -C foo he can create file foo with uucp as group
owner. I hacked this ugly little patch that tries to fix this 
(attached separately). Please note that I haven't had time to fully test
this patch so it's quite possible it will break something !!

-Jarno

Comment 1 Jarno Huuskonen 2000-08-24 10:14:22 UTC
Created attachment 2899 [details]
ugly patch to set egid to real_gid before opening -C file

Comment 2 Bill Nottingham 2000-08-24 23:32:08 UTC

*** This bug has been marked as a duplicate of 16738 ***


Note You need to log in before you can comment on or make changes to this bug.