Bug 1685302 - Rebase of PCP
Summary: Rebase of PCP
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: pcp
Version: 8.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Nathan Scott
QA Contact: Michal Kolar
Vladimír Slávik
URL:
Whiteboard:
: 1600746 1664871 (view as bug list)
Depends On: 1682583
Blocks: 1701002 1664871 1683651
TreeView+ depends on / blocked
 
Reported: 2019-03-04 23:02 UTC by Nathan Scott
Modified: 2019-11-07 05:23 UTC (History)
12 users (show)

Fixed In Version: pcp-4.3.2-2
Doc Type: Enhancement
Doc Text:
.Performance Co-Pilot rebased to version 4.3.2 In RHEL 8.1, the Performance Co-Pilot (PCP) tool has been updated to upstream version 4.3.2. Notable improvements include: * New metrics have been added - Linux kernel entropy, pressure stall information, Nvidia GPU statistics, and more. * Tools such as `pcp-dstat`, `pcp-atop`, the `perfevent` PMDA, and others have been updated to report the new metrics. * The `pmseries` and `pmproxy` utilities for a performant PCP integration with Grafana have been updated. This release is backward compatible for libraries, over-the-wire protocol and on-disk PCP archive format.
Clone Of:
Environment:
Last Closed: 2019-11-05 20:55:05 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Legacy) 3796461 None None None 2019-05-15 21:48:13 UTC
Red Hat Knowledge Base (Solution) 3796461 Troubleshoot None Why does pcp dstat --time show only timestamps 2019-05-28 11:59:42 UTC
Red Hat Product Errata RHBA-2019:3364 None None None 2019-11-05 20:55:18 UTC

Description Nathan Scott 2019-03-04 23:02:03 UTC
We're planning a rebase of the RHEL-8 package of PCP for 8.1.  This rebase contains many bug fixes as well as new features.  Backward compatibility is maintained (unchanged) for libraries, over-the-wire protocol and on-disk PCP archive format.

New features include addition of new metrics - Linux kernel entropy, pressure stall information, Nvidia GPU statistics - as well as updates to tools like pcp-dstat(1) and pcp-atop(1) to report these metrics.  The perfevent PMDA used extensively by partners (IBM, Fujitsu) is also updated to include several of their newly requested metrics.  A number of updates to the pmseries(1) and pmproxy(1) utility to provide a performant PCP / Grafana integration will also be included.

Comment 2 Nathan Scott 2019-03-20 00:13:37 UTC
*** Bug 1600746 has been marked as a duplicate of this bug. ***

Comment 4 Nathan Scott 2019-05-13 23:03:01 UTC
*** Bug 1709237 has been marked as a duplicate of this bug. ***

Comment 5 Nathan Scott 2019-05-14 03:21:57 UTC
This BZ (and related build) remains blocked from entering 8.1 due to CI/gating a week or so after the build - can I get some further assistance there please Martin/Michal?

I'm seeing other QE folk opening BZs for issues that are fixed already in this build.  :(

Comment 6 Nathan Scott 2019-05-15 21:48:13 UTC
*** Bug 1664871 has been marked as a duplicate of this bug. ***

Comment 8 Nathan Scott 2019-05-17 04:22:44 UTC
*** Bug 1709237 has been marked as a duplicate of this bug. ***

Comment 11 Michal Kolar 2019-08-28 07:10:27 UTC
Verified against pcp-4.3.2-2.el8.

Comment 13 errata-xmlrpc 2019-11-05 20:55:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3364

Comment 14 Christian Horn 2019-11-06 07:34:57 UTC
Hm.. the release notes have the incorrect "Performance Co-Pilot rebased to version 8.1".
https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/8/html-single/8.1_release_notes/index
Should we reopen this bz or open an other one?


Note You need to log in before you can comment on or make changes to this bug.