Bug 1685363 - fedora netinstall images have wrong /etc/multipath.conf
Summary: fedora netinstall images have wrong /etc/multipath.conf
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lorax   
(Show other bugs)
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-05 03:46 UTC by Ben Marzinski
Modified: 2019-03-22 18:02 UTC (History)
9 users (show)

Fixed In Version: lorax-30.17-1 lorax-30.17-1.fc30
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2019-03-22 18:02:50 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ben Marzinski 2019-03-05 03:46:21 UTC
Description of problem:
The fedora netinstall image used a multipath.conf of
**********

defaults {
        find_multipaths yes
        user_friendly_names yes
}

**********
It should be using the default multipath.conf generated with

# mpathconf --enable

Which is
**********

defaults {
        user_friendly_names yes
        find_multipaths yes
}

blacklist_exceptions {
        property "(SCSI_IDENT_|ID_WWN)"
}

**********

The incorrect multipath.conf file allows multipathd to attempt to setup multipath on devices that it shouldn't. This was the root cause for Bug #1672761.

I'm not sure if pungi is responsible for adding this file to the netinstall image. If not, could you please reassign the bug to the component responsible.

Comment 1 Brian Lane 2019-03-05 20:07:24 UTC
https://github.com/weldr/lorax/pull/632

Comment 2 Fedora Update System 2019-03-15 19:52:18 UTC
lorax-30.17-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-5edfcfd391

Comment 3 Fedora Update System 2019-03-16 20:18:10 UTC
lorax-30.17-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-5edfcfd391

Comment 4 Fedora Update System 2019-03-22 18:02:50 UTC
lorax-30.17-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.