Bug 1685399 - [REF] Should prompt error when do build using incorrect Config build.config.openshift.io/cluster
Summary: [REF] Should prompt error when do build using incorrect Config build.config....
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Adam Kaplan
QA Contact: wewang
URL:
Whiteboard: 4.1.3
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-05 06:24 UTC by wewang
Modified: 2019-06-26 08:50 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-26 08:50:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:1589 None None None 2019-06-26 08:50:29 UTC

Description wewang 2019-03-05 06:24:54 UTC
Description of problem:
Should prompt error when do build using config incorrect Config build.config.openshift.io/cluster

Version-Release number of selected component (if applicable):
image: registry.svc.ci.openshift.org/ocp/release@sha256:307df808e90e18a0e1730e68cfa1ccb9c9888ee460b86d62118be690fd9e0079
version: 4.0.0-0.nightly-2019-03-04-234414

How reproducible:
always

Steps to Reproduce:
1.Create cluster with invalid proxy setting in cluster-config.yaml
$ oc create -f cluster-config.yaml
kind: Build
apiVersion: config.openshift.io/v1
metadata:
  name: cluster
spec:
  buildDefaults:
    defaultProxy:
    - httpProxy: http://invalid.rdu.redhat.com:3128
      httpsProxy: https://invalid.rdu.redhat.com:3128

2.Create project and create app
$ oc new-app -f https://raw.githubusercontent.com/openshift/origin/master/examples/sample-app/application-template-stibuild.json -n wewang2

3.Build complete

Actual results:
No prompt about invalid cluster config

Expected results:
Should give error prompt about invalid cluster config 

Additional info:
This is a ref bug from https://bugzilla.redhat.com/show_bug.cgi?id=1677585#c20

Comment 1 Adam Kaplan 2019-03-06 19:12:46 UTC
@wewang is this going to be converted to an RFE,? See https://bugzilla.redhat.com/show_bug.cgi?id=1677585#c20
I don't consider this to be a blocker for 4.0 release.

Comment 2 wewang 2019-03-07 03:31:07 UTC
Yeah, it's not block 4.0 release, just a ref and updated title.

Comment 4 Kirsten Newcomer 2019-06-11 21:40:44 UTC
With the introduction of OpenShift 4, Red Hat has delivered or roadmapped a substantial number of features based on feedback by our customers.  Many of the enhancements encompass specific RFEs which have been requested, or deliver a comparable solution to a customer problem, rendering an RFE redundant.

This bz (RFE) has been identified as a feature request not yet planned or scheduled for an OpenShift release and is being closed. 

If this feature is still an active request that needs to be tracked, Red Hat Support can assist in filing a request in the new JIRA RFE system, as well as provide you with updates as the RFE progress within our planning processes. Please open a new support case: https://access.redhat.com/support/cases/#/case/new 

Opening a New Support Case: https://access.redhat.com/support/cases/#/case/new 

As the new Jira RFE system is not yet public, Red Hat Support can help answer your questions about your RFEs via the same support case system.

Comment 5 Adam Kaplan 2019-06-12 15:45:09 UTC
This was fixed in 4.1.0. PR: https://github.com/openshift/cluster-config-operator/pull/17

QE should be able to verify.

Comment 6 wewang 2019-06-13 02:26:24 UTC
Verified in version:
4.1.0-0.nightly-2019-06-10-195531

prompt info
# builds.config.openshift.io "cluster" was not valid:
# * []: Invalid value: map[string]interface {}{"apiVersion":"config.openshift.io/v1", "kind":"Build", "metadata":map[string]interface {}{"name":"cluster", "uid":"abffdd1b-8cd8-11e9-82c7-02da36e058d8", "resourceVersion":"1482", "generation":2, "creationTimestamp":"2019-06-12T06:09:43Z", "annotations":map[string]interface {}{"release.openshift.io/create-only":"true"}}, "spec":map[string]interface {}{"buildDefaults":map[string]interface {}{"defaultProxy":[]interface {}{map[string]interface {}{"httpProxy":"http://invalid.rdu.redhat.com:3128", "httpsProxy":"https://invalid.rdu.redhat.com:3128"}}}}}: validation failure list:
# spec.buildDefaults.defaultProxy in body must be of type object: "array"
#
apiVersion: config.openshift.io/v1
kind: Build
metadata:
  annotations:
    release.openshift.io/create-only: "true"
  creationTimestamp: "2019-06-12T06:09:43Z"
  generation: 1
  name: cluster
  resourceVersion: "1482"
  selfLink: /apis/config.openshift.io/v1/builds/cluster
  uid: abffdd1b-8cd8-11e9-82c7-02da36e058d8
spec:
  buildDefaults:
    defaultProxy:
    - httpProxy: http://invalid.rdu.redhat.com:3128
      httpsProxy: https://invalid.rdu.redhat.com:3128
~

Comment 9 errata-xmlrpc 2019-06-26 08:50:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1589


Note You need to log in before you can comment on or make changes to this bug.