Bug 1685411 - openshift-service-cert-signer image build from a obsolete repo
Summary: openshift-service-cert-signer image build from a obsolete repo
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Release
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.1.0
Assignee: Tim Bielawa
QA Contact: Chuan Yu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-05 07:03 UTC by Chuan Yu
Modified: 2019-06-04 10:45 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:45:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:45:12 UTC

Description Chuan Yu 2019-03-05 07:03:41 UTC
Description of problem:
Repo openshift/service-serving-cert-signer has renamed to openshift/service-ca-operator for a while, but the openshift-service-cert-signer image still build from a obsolete repo

Version-Release number of selected component (if applicable):
$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.0.0-0.nightly-2019-03-04-234414   True        False         172m    Cluster version is 4.0.0-0.nightly-2019-03-04-234414

How reproducible:

# TAG_ID=2019-03-04-234414

# oc adm release info --pullspecs registry.svc.ci.openshift.org/ocp/release:4.0.0-0.nightly-${TAG_ID} | grep service-serving
  service-serving-cert-signer                   quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:032cf8f0fd7ac91f58ee670244892812cd024d8d7eee923266b9acf97ee21ac4

# oc image info quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:032cf8f0fd7ac91f58ee670244892812cd024d8d7eee923266b9acf97ee21ac4
Name:        quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:032cf8f0fd7ac91f58ee670244892812cd024d8d7eee923266b9acf97ee21ac4
...
             io.k8s.description=This is the base image from which all OpenShift Container Platform images inherit.
             io.k8s.display-name=OpenShift Container Platform RHEL 7 Base
             io.openshift.build.commit.id=309242162ed5bcf9398fca0ba9418244ec7c6808
             io.openshift.build.commit.url=https://github.com/openshift/service-serving-cert-signer/commit/309242162ed5bcf9398fca0ba9418244ec7c6808
             io.openshift.build.source-location=https://github.com/openshift/service-serving-cert-signer
...


Actual results:


Expected results:


Additional info:

Comment 3 Chuan Yu 2019-03-20 00:46:27 UTC
The issue should be fixed now, build repo point to the right one.

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.0.0-0.nightly-2019-03-18-223058   True        False         23h     Cluster version is 4.0.0-0.nightly-2019-03-18-223058

Comment 5 errata-xmlrpc 2019-06-04 10:45:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.