Bug 1685815 - System upgrade is stopped after fwupd-offline-update.service failure
Summary: System upgrade is stopped after fwupd-offline-update.service failure
Keywords:
Status: CLOSED DUPLICATE of bug 1685471
Alias: None
Product: Fedora
Classification: Fedora
Component: fwupd
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-06 07:57 UTC by Ondrej Holy
Modified: 2019-03-12 10:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-12 10:05:55 UTC


Attachments (Terms of Use)

Description Ondrej Holy 2019-03-06 07:57:33 UTC
Description of problem:
Yesterday, I tried to upgrade to Fedora 30 on my Lenovo T480s with up-to-date Fedora 29, however, fwupd-offline-update.service failure caused that systemd stopped all other services including the dnf-system-upgrade.

Version-Release number of selected component (if applicable):
fwupd-1.2.5-1.fc29.x86_64
dnf-4.1.0-1.fc29.noarch
python3-dnf-plugin-system-upgrade-4.0.2-1.fc29.noarch

How reproducible:
I tried the system-upgrade three times and it failed the same way in both cases, so it seems that it is always reproducible in my case...

Steps to Reproduce:
1. sudo dnf upgrade --refresh
2. sudo dnf system-upgrade download --releasever=30 --allowerasing
3. sudo dnf system-upgrade reboot

Actual results:
Mar 05 19:56:17 t480s dbus-daemon[1078]: [system] Failed to activate service 'org.freedesktop.fwupd': timed out (service_start_timeout=25000ms)
Mar 05 19:56:17 t480s fwupdmgr[1072]: Failed to connect to daemon: Error calling StartServiceByName for org.freedesktop.fwupd: GDBus.Error:org.freedesktop.DBus.Error.TimedO>
Mar 05 19:56:17 t480s systemd[1]: fwupd-offline-update.service: Main process exited, code=exited, status=1/FAILURE
Mar 05 19:56:17 t480s systemd[1]: fwupd-offline-update.service: Failed with result 'exit-code'.
Mar 05 19:56:17 t480s systemd[1]: fwupd-offline-update.service: Triggering OnFailure= dependencies.
...
Mar 05 19:56:17 t480s systemd[1]: dnf-system-upgrade.service: Main process exited, code=killed, status=15/TERM
Mar 05 19:56:17 t480s systemd[1]: dnf-system-upgrade.service: Failed with result 'signal'.
Mar 05 19:56:17 t480s systemd[1]: Stopped System Upgrade using DNF.
Mar 05 19:56:17 t480s systemd[1]: dnf-system-upgrade.service: Triggering OnFailure= dependencies.

Expected results:
fwupd-offline-update.service should not fail and dnf-system-upgrade.service should upgrade the system.

Additional info:
Is there any additional info I can provide before I will try to remove fwupd as a workaround?

Comment 1 krinkodot22 2019-03-07 19:48:54 UTC
This looks like a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1685471

Comment 2 Ondrej Holy 2019-03-12 10:05:55 UTC

*** This bug has been marked as a duplicate of bug 1685471 ***


Note You need to log in before you can comment on or make changes to this bug.