Bug 1685878 - [RHEL-8] ibacm[28289]: segfault at 0 ip 0000557b5cdf69da sp 00007ffe54175100 error 4 in ibacm[557b5cdf1000+e000]
Summary: [RHEL-8] ibacm[28289]: segfault at 0 ip 0000557b5cdf69da sp 00007ffe54175100 ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: rdma-core
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: 8.0
Assignee: Jarod Wilson
QA Contact: zguo
URL:
Whiteboard:
Depends On: 1722257
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-06 08:47 UTC by zguo
Modified: 2020-04-28 16:57 UTC (History)
4 users (show)

Fixed In Version: rdma-core-26.0-3.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:56:49 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2020:1865 None None None 2020-04-28 16:57:43 UTC

Description zguo 2019-03-06 08:47:18 UTC
Description of problem:

Version-Release number of selected component (if applicable):

+ [19-03-01 16:41:08] '[' multi == multi ']'
+ [19-03-01 16:41:08] echo 'Clients: rdma-qe-25.lab.bos.redhat.com'
Clients: rdma-qe-25.lab.bos.redhat.com
+ [19-03-01 16:41:08] echo 'Servers: rdma-qe-24.lab.bos.redhat.com'
Servers: rdma-qe-24.lab.bos.redhat.com
+ [19-03-01 16:41:08] RQA_system_info_for_debug
+ [19-03-01 16:41:08] grep -i distro /etc/motd
+ [19-03-01 16:41:08] tr -d ' '
DISTRO=RHEL-8.0.0-20190228.1
+ [19-03-01 16:41:08] cat /etc/redhat-release
Red Hat Enterprise Linux release 8.0 Beta (Ootpa)
+ [19-03-01 16:41:08] uname -a
Linux rdma-qe-25.lab.bos.redhat.com 4.18.0-74.el8.x86_64 #1 SMP Wed Feb 27 17:53:43 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
+ [19-03-01 16:41:08] cat /proc/cmdline
BOOT_IMAGE=(hd0,gpt2)/vmlinuz-4.18.0-74.el8.x86_64 root=UUID=4bca4dfc-1faf-4892-a9c7-7b2548eaaa68 ro crashkernel=auto resume=UUID=6090cd82-083a-4007-9188-579060b22084 console=ttyS0,115200n81
+ [19-03-01 16:41:08] rpm -q rdma-core
rdma-core-22-2.el8.x86_64

How reproducible:


Steps to Reproduce:
1. Hit this issue when running our ibacm automation testing, still not sure which steps triggered it.
https://beaker.engineering.redhat.com/recipes/6561989#task88901516
https://beaker.engineering.redhat.com/recipes/6561989/tasks/88901516/results/410108013/logs/dmesg.log
3.

Actual results:
[ 3815.057079] ibacm[28289]: segfault at 0 ip 0000557b5cdf69da sp 00007ffe54175100 error 4 in ibacm[557b5cdf1000+e000]
[ 3815.067510] Code: 8b 05 2a 89 20 00 48 8d 35 23 89 20 00 48 8d 58 f0 48 39 f0 74 49 48 8b 43 20 48 8d 53 20 48 39 d0 74 2f 49 8b 8e c8 00 00 00 <48> 8b 09 48 39 48 10 75 17 e9 98 00 00 00 0f 1f 84 00 00 00 00 00

Expected results:
No segfault

Additional info:

Comment 9 Jarod Wilson 2019-07-25 21:18:47 UTC
We should pick this up in 8.2 via updating to v24 or v25 rdma-core.

Comment 10 Jarod Wilson 2019-11-21 18:00:18 UTC
(In reply to Jarod Wilson from comment #9)
> We should pick this up in 8.2 via updating to v24 or v25 rdma-core.

Or v26, which is now built and ready for RHEL-8.2.

Comment 13 errata-xmlrpc 2020-04-28 16:56:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:1865


Note You need to log in before you can comment on or make changes to this bug.