Bug 168593 - Review Request: pydot: Python interface to Graphviz's Dot language
Review Request: pydot: Python interface to Graphviz's Dot language
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael A. Peters
David Lawrence
http://dkbza.org/pydot.html
:
Depends On:
Blocks: FE-ACCEPT
  Show dependency treegraph
 
Reported: 2005-09-17 14:56 EDT by Tom "spot" Callaway
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-07 01:28:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom "spot" Callaway 2005-09-17 14:56:50 EDT
Spec Name or Url: http://www.auroralinux.org/people/spot/review/pydot.spec
SRPM Name or Url: http://www.auroralinux.org/people/spot/review/pydot-0.9.10-1.src.rpm
Description: 
An interface for creating both directed and non directed graphs from Python.
Currently all attributes implemented in the Dot language are supported (up
to Graphviz 1.16).

Output can be inlined in Postscript into interactive scientific environments
like TeXmacs, or output in any of the format's supported by the Graphviz
tools dot, neato, twopi.
Comment 1 Michael A. Peters 2005-10-06 13:22:24 EDT
md5sum matches upstream
builds clean in mock
rpmlint doesn't complain
License matches readme and license file

-=-
from the readme:

Requirements:
-------------

pyparsing: pydot requires the pyparsing module in order to be
        able to load DOT files.

GraphViz:  is needed in order to render the graphs into any of
        the plethora of output formats supported.

These are listed as BuildRequires - but yum did not pull in pyparsing (not
installed) when I ran yum localinstall, and rpm did not complain when I tried
rpm --test -e graphviz

Did you mean that to be Requires and not BuildRequires?
Comment 2 Tom "spot" Callaway 2005-10-06 13:31:30 EDT
Yes, those should be Requires... my bad. I'll change them before commit.
Comment 3 Michael A. Peters 2005-10-06 21:20:49 EDT
* Spec file readable
* Group appropriate
* Proper use of Macros
* Software works - tested in fc4

APPROVED w/ comment2 changes

Note You need to log in before you can comment on or make changes to this bug.