Bug 168597 - FEAT RHEL3 U7: add dell_rbu driver for Dell BIOS updates
Summary: FEAT RHEL3 U7: add dell_rbu driver for Dell BIOS updates
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brian Maly
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks: 168424
TreeView+ depends on / blocked
 
Reported: 2005-09-17 19:57 UTC by Issue Tracker
Modified: 2007-11-30 22:07 UTC (History)
5 users (show)

Fixed In Version: RHSA-2006-0144
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-15 16:39:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dell_rbu-RHEL3.patch (34.08 KB, patch)
2005-10-07 17:23 UTC, Larry Troan
no flags Details | Diff
dell_rbu-2.1.RHEL3.patch (36.27 KB, patch)
2005-11-15 22:07 UTC, douglas_warzecha
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2006:0144 qe-ready SHIPPED_LIVE Moderate: Updated kernel packages available for Red Hat Enterprise Linux 3 Update 7 2006-03-15 05:00:00 UTC

Description Issue Tracker 2005-09-17 19:57:44 UTC
Escalated to Bugzilla from IssueTracker

Comment 3 Issue Tracker 2005-09-17 19:57:59 UTC
From User-Agent: XML-RPC

Here is a patch to kernel-2.4.21-37.EL.

Status set to: Waiting on Tech

This event sent from IssueTracker by ltroan
 issue 80013

Comment 5 Issue Tracker 2005-09-17 19:59:28 UTC
From User-Agent: XML-RPC

I've attached the patch file dell_rbu-RHEL4.patch. This patch creates
firmware/dell_rbu.c, Documentation/dell_rbu.txt and updates the Kconfig and
Makefile. I've verified the patch by building a kernel image. The patch
was made against kernel source 2.6.9-20 taken from the daily kernel
builds.


This event sent from IssueTracker by ltroan
 issue 72583

Comment 8 Larry Troan 2005-10-07 17:22:07 UTC
Does Dell have a RHEL3U7 equivalent of the patch they provided for RHEL4U3?

Comment 9 Larry Troan 2005-10-07 17:23:55 UTC
Created attachment 119716 [details]
dell_rbu-RHEL3.patch

Comment 10 Ernie Petrides 2005-10-07 21:30:54 UTC
Larry Troan, please uncheck the "Dell ESG" box below.  You just prevented
most people from being about to view this bugzilla.  Thanks in advance.

Comment 12 Ernie Petrides 2005-10-11 21:36:47 UTC
Reverting to public bugzilla (undoing Larry Troan's "Dell ESG" box check).


Comment 16 Matt Domsch 2005-11-04 15:21:13 UTC
dell_rbu is in Linus's 2.6.14-final tree.  There's one additional patch sent 
this week which prevents rbu packet allocations from being below 1MB to deal 
with a BIOS limitation we hadn't realized existed.

Comment 18 Larry Troan 2005-11-10 03:55:55 UTC
Per comment #12, Ernie opened this up as a Public bug.

All future activity should be recorded directly in the bug. 

Comment 19 douglas_warzecha 2005-11-15 22:07:10 UTC
Created attachment 121096 [details]
dell_rbu-2.1.RHEL3.patch

This patch adds the dell_rbu driver to the RHEL 3 kernel and includes support
for the packet RBU allocation floor changes that were accepted upstream in
kernel 2.6.15-rc1.

Comment 20 Issue Tracker 2005-12-01 12:53:48 UTC
From User-Agent: XML-RPC

Patch submitted very late in update cycle. 



Engineering/QA, can we still get this into U7? It's already on the CANFIX
list.


This event sent from IssueTracker by ltroan
 issue 80013

Comment 21 Larry Troan 2005-12-01 12:58:46 UTC
Correction to comment #20. 

Initial patch was submitted on 9/16 by Dell. Obsoleted/replaced by current
attached patch on 11/15 per comment #19 above. 

The bug is still in the ASSIGNED state. Question remains..... can we still get
this into U7? It's already on the CANFIX list.

Comment 22 Ernie Petrides 2005-12-02 01:16:21 UTC
The new dell_rbu driver has just been committed to the RHEL3 U7
patch pool this evening (in kernel version 2.4.21-38.EL).


Comment 26 Red Hat Bugzilla 2006-03-15 16:39:00 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHSA-2006-0144.html



Note You need to log in before you can comment on or make changes to this bug.