Bug 1685983 - [RFE] Support IPv6 for address type in subnets in rhel8 guests
Summary: [RFE] Support IPv6 for address type in subnets in rhel8 guests
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-provider-ovn
Classification: oVirt
Component: provider
Version: unspecified
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ovirt-4.3.4
: 1.2.22
Assignee: Miguel Duarte Barroso
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-06 13:15 UTC by Michael Burman
Modified: 2019-06-11 06:24 UTC (History)
5 users (show)

Fixed In Version: ovirt-provider-ovn-1.2.22
Doc Type: Enhancement
Doc Text:
This feature adapts the existing IPv6 address support for OpenStack Networking API subnets, making its address mode configurable, as per the networking API subnet 'address_mode' parameter. The addresses can now be generated from RA messages, when the address mode parameter is set to 'dhcpv6_stateless'. This configuration also allows for the MTU of the logical network to be configured, which would be otherwise impossible for ipv6 logical networks.
Clone Of:
Environment:
Last Closed: 2019-06-11 06:24:10 UTC
oVirt Team: Network


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 98496 master MERGED api: dhcpv6_stateless is now a valid address mode 2019-04-04 07:31:09 UTC
oVirt gerrit 98497 master MERGED Configure OVN logical router port for ipv6 2019-04-04 07:31:16 UTC
oVirt gerrit 98789 master MERGED ipv6: add mtu option to RA messages 2019-04-09 12:34:19 UTC
oVirt gerrit 98986 master MERGED ipv6: set the subnet default address mode 2019-04-11 14:15:22 UTC
oVirt gerrit 99193 master MERGED Fix bug when fixed IPs are not provisioned 2019-04-08 07:24:19 UTC

Description Michael Burman 2019-03-06 13:15:28 UTC
Description of problem:
[RFE] Support IPv6 for address type in subnets in rhel8 guests

In rhel8 guests/VMs, we can't ping networks via the IPv6 subnets without RA.
In rhel7.6 VMs we could, see BZ 1434435 comment11.
We should support connectivity between IPv6 subnets in rhel8 guests. 

Since on el8, the default is for dhclient to assign ipv6 host addresses (/128 subnets)

Version-Release number of selected component (if applicable):
ovirt-provider-ovn-1.2.20-1.el7ev.noarch
rhvm-4.3.2-0.1.el7.noarch

How reproducible:
100% 

Steps to Reproduce:
1. Create IPv6 network and subnet via REST API on the ovn provider
2. Import the network to RHV
3. Add this network to 2 rhel8 VMs
4. Run dhclient -6 on both VMs and get IPv6 addresses from the dhcpv6 subnet
5. Try to ping between the 2 VMs via the IPv6 addresses 

Actual results:
'Network is unreachable'.

Expected results:
Ping should work via the same IPv6 subnet

Additional info:
See also main RFE BZ 1434435 which was tested with success with rhel7.6 VMs and working as expected.

Comment 1 Michael Burman 2019-05-21 07:09:36 UTC
Verified on - ovirt-provider-ovn-1.2.22-1.el7ev.noarch with
ovirt-engine-4.3.4-0.1.el7.noarch
rhv-openvswitch-2.10-6.el7ev.noarch
rhv-openvswitch-ovn-common-2.10-6.el7ev.noarch
rhv-openvswitch-ovn-host-2.10-6.el7ev.noarch
openvswitch2.10-2.10.0-28.el7fdp.3.x86_64
openvswitch2.10-ovn-common-2.10.0-28.el7fdp.3.x86_64
openvswitch2.10-ovn-central-2.10.0-28.el7fdp.3.x86_64
ovirt-provider-ovn-driver-1.2.22-1.el7ev.noarch
vdsm-4.30.15-1.el7ev.x86_64

VMs/guests:
kernel 4.18.0-32.el8.x86_64
rhel8.0

Comment 2 Sandro Bonazzola 2019-06-11 06:24:10 UTC
This bugzilla is included in oVirt 4.3.4 release, published on June 11th 2019.

Since the problem described in this bug report should be
resolved in oVirt 4.3.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.