Bug 1685992 - Network spoke doesn't appear on ARM initial-setup
Summary: Network spoke doesn't appear on ARM initial-setup
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: initial-setup   
(Show other bugs)
Version: 30
Hardware: armhfp
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Kolman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker AcceptedFreezeException
Keywords:
Depends On:
Blocks: BetaFreezeException, F30BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2019-03-06 13:50 UTC by Alessio
Modified: 2019-03-18 20:41 UTC (History)
7 users (show)

Fixed In Version: initial-setup-0.3.68-1 initial-setup-0.3.68-1.fc30
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2019-03-18 20:41:49 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
journalctl > journal.dump (326.97 KB, text/plain)
2019-03-06 15:15 UTC, Alessio
no flags Details

Description Alessio 2019-03-06 13:50:23 UTC
Initial setup doesn't offer the option to configure the network.

Tested with these images
Fedora-Minimal-armhfp-30-20190301.n.0-sda.raw.xz
Fedora-Server-armhfp-30-20190301.n.0-sda.raw.xz

Tested on an OrangePi PC and on a Raspberry Pi 3.
Using serial console as well as HDMI.

Comment 1 Fedora Blocker Bugs Application 2019-03-06 13:58:57 UTC
Proposed as a Blocker for 30-beta by Fedora user alciregi using the blocker tracking app because:

 I think that this criteria is not meet: "The installer must be able to complete an installation using the serial console interface. "
Or this one: "The installer must be able to complete an installation using all supported interfaces."

Comment 2 Martin Kolman 2019-03-06 14:52:47 UTC
(In reply to Alessio from comment #0)
> Initial setup doesn't offer the option to configure the network.
> 
> Tested with these images
> Fedora-Minimal-armhfp-30-20190301.n.0-sda.raw.xz
> Fedora-Server-armhfp-30-20190301.n.0-sda.raw.xz
> 
> Tested on an OrangePi PC and on a Raspberry Pi 3.
> Using serial console as well as HDMI.
Can you attach a journal dump from the system when this happens ? Initial Setup logs to Journal, so all it's (any any potentially relevant system messages) should be in the dump.

Thanks in advance! :)

Comment 3 Alessio 2019-03-06 15:15 UTC
Created attachment 1541446 [details]
journalctl > journal.dump

Is this ok?

Comment 4 Paul Whalen 2019-03-06 18:32:06 UTC
Seems to only affect initial-setup-tui, graphical images include the network spoke.

Comment 5 Martin Kolman 2019-03-06 18:41:54 UTC
(In reply to Alessio from comment #3)
> Created attachment 1541446 [details]
> journalctl > journal.dump
> 
> Is this ok?

Yep, thanks a lot! :)

Looks like we have found the root cause - a recently introduced variable, that's now used to decide if the network spoke should be shown has an unexpected value when running in Initial Setup. (In reply to Paul Whalen from comment #4)

> Seems to only affect initial-setup-tui, graphical images include the network
> spoke.
The graphical network spoke likely still uses the "old" way to detect if it should run and is this not affected.


Anyway, the fix should not be too hard & fix should be coming shortly. :)

Comment 6 Martin Kolman 2019-03-11 14:41:01 UTC
PRs:
https://github.com/rhinstaller/initial-setup/pull/64
https://github.com/rhinstaller/anaconda/pull/1880

Thanks a lot to vponcova for the quick fix! :)

Comment 7 Geoffrey Marr 2019-03-11 20:24:37 UTC
Discussed during the 2019-03-11 blocker review meeting: [1]

The decision to classify this bug as a "RejectedBlocker" and an "AcceptedFreezeException" was made as we find that the network spoke is more a convenience than a vital feature of i-s in this workflow, and there is no criterion requiring it to be present or work. However, this is obviously a significant bug that cannot be fixed with an update, so we grant it Freeze Exception status.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2019-03-11/f30-blocker-review.2019-03-11-16.04.txt

Comment 8 Radek Vykydal 2019-03-12 12:40:49 UTC
This PR should fix additional issue - network devices not being configurable in TUI:
https://github.com/rhinstaller/initial-setup/pull/65

Comment 9 Fedora Update System 2019-03-12 18:08:05 UTC
initial-setup-0.3.68-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-3e39ada0bd

Comment 10 Fedora Update System 2019-03-18 19:42:54 UTC
anaconda-30.25.3-4.fc30 initial-setup-0.3.68-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-3e39ada0bd

Comment 11 Fedora Update System 2019-03-18 20:41:49 UTC
anaconda-30.25.3-4.fc30, initial-setup-0.3.68-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.