Bug 1686107 - Dirty exception when failing dependencies of a build
Summary: Dirty exception when failing dependencies of a build
Keywords:
Status: CLOSED DUPLICATE of bug 1696234
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: mock
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-06 18:05 UTC by Phil Wyett
Modified: 2019-04-22 17:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-22 17:11:55 UTC
Type: Bug


Attachments (Terms of Use)

Description Phil Wyett 2019-03-06 18:05:59 UTC
Description of problem:

Dirty exception when failing dependencies of a build.

Error: No Package found for libfilezilla-devel >= 0.9.2
Error: No Package found for libstorj-devel
Error: No Package found for wxGTK3-devel >= 3.0.3
ERROR: Exception(SRPMS/filezilla-3.41.0-1.fc31.src.rpm) Config(epel-7-x86_64) 0 minutes 4 seconds
INFO: Results and/or logs in: /var/lib/mock/epel-7-x86_64/result
ERROR: global name 'FileNotFoundError' is not defined
Traceback (most recent call last):
  File "/usr/libexec/mock/mock", line 977, in <module>
    main()
  File "/usr/lib/python2.7/site-packages/mockbuild/trace_decorator.py", line 96, in trace
    result = func(*args, **kw)
  File "/usr/libexec/mock/mock", line 766, in main
    run_command(options, args, config_opts, commands, buildroot, state)
  File "/usr/lib/python2.7/site-packages/mockbuild/trace_decorator.py", line 96, in trace
    result = func(*args, **kw)
  File "/usr/libexec/mock/mock", line 861, in run_command
    do_rebuild(config_opts, commands, buildroot, options, args)
  File "/usr/lib/python2.7/site-packages/mockbuild/trace_decorator.py", line 96, in trace
    result = func(*args, **kw)
  File "/usr/libexec/mock/mock", line 541, in do_rebuild
    post=post_build, clean=clean)
  File "/usr/lib/python2.7/site-packages/mockbuild/trace_decorator.py", line 96, in trace
    result = func(*args, **kw)
  File "/usr/libexec/mock/mock", line 482, in rebuild_generic
    ret = cmd(item)
  File "/usr/libexec/mock/mock", line 522, in build
    check=config_opts['check'], spec=options.spec)
  File "/usr/lib/python2.7/site-packages/mockbuild/trace_decorator.py", line 96, in trace
    result = func(*args, **kw)
  File "/usr/lib/python2.7/site-packages/mockbuild/backend.py", line 275, in build
    self.installSrpmDeps(rebuilt_srpm)
  File "/usr/lib/python2.7/site-packages/mockbuild/trace_decorator.py", line 96, in trace
    result = func(*args, **kw)
  File "/usr/lib/python2.7/site-packages/mockbuild/backend.py", line 203, in installSrpmDeps
    self.buildroot.pkg_manager.builddep(*srpms, check=True)
  File "/usr/lib/python2.7/site-packages/mockbuild/trace_decorator.py", line 96, in trace
    result = func(*args, **kw)
  File "/usr/lib/python2.7/site-packages/mockbuild/package_manager.py", line 162, in builddep
    except (FileNotFoundError) as error:
NameError: global name 'FileNotFoundError' is not defined

Version-Release number of selected component (if applicable):

1.4.14-2

How reproducible:

Always

Steps to Reproduce:
1. Download 'filezilla-3.41.0-1.fc31.src.rpm' from fedora packages site.
2. Build with mock using 'epel-7-x86_64' config.

Actual results:

Exception and trace as seen above.

Expected results:

A clean failure with no exception.

Comment 1 Miroslav Suchý 2019-04-22 17:11:55 UTC

*** This bug has been marked as a duplicate of bug 1696234 ***


Note You need to log in before you can comment on or make changes to this bug.