Bug 168614 - No sound on Dell 9300 by default.
No sound on Dell 9300 by default.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: alsa-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-18 01:07 EDT by Rodd Clarkson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 05:52:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rodd Clarkson 2005-09-18 01:07:41 EDT
Description of problem:

Hopefully, this is posted in the right place.  If not then moved it.

By default, sound doesn't play on my laptop after installing FC4 and rawhide. 
The problem lies in the value of a single switch in the alsa settings.

The sound card is as follows (using lspci):

00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW
(ICH6 Family) AC'97 Audio Controller (rev 03)

To solve the problem I have to do this:

1. Click Applications > Sound and Video > Volume Control
2. Select Edit > Preferences
3. Select External Amplifier from the list.  It's down the bottom and it's not
checked by default.
4. In the Volume Control dialog, select the switches tab and then check external
amplifier (again, it's not checked by default).

Now sound works.

While external amplifier doesn't need to be in the Volume Control dialog, it
seems that, for my sound card, it needs to be on by default.
Comment 1 Martin Stransky 2005-09-19 03:49:24 EDT
Which driver do you use? If I understand well, you need to mute this switch?
Comment 2 Rodd Clarkson 2005-09-19 05:06:49 EDT
I didn't actually choose a driver.  I just took the default that was offered. 
During firstboot the sound card check doesn't work, but I ignored it knowing
that I could fix it later.

The driver appears to be: snd_intel8x0m

Here's the output of /sbin/lsmod

[rodd@localhost ~]$ /sbin/lsmod
Module                  Size  Used by
arc4                    1985  1
ieee80211_crypt_wep     4801  1
udf                    83781  1
parport_pc             27909  0
lp                     12937  0
parport                35465  2 parport_pc,lp
autofs4                19525  2
rfcomm                 38873  0
l2cap                  25921  5 rfcomm
bluetooth              48069  4 rfcomm,l2cap
sunrpc                141437  1
ipt_REJECT              5953  1
ipt_state               1985  2
ip_conntrack           51473  1 ipt_state
nfnetlink               6617  1 ip_conntrack
iptable_filter          3009  1
ip_tables              20161  3 ipt_REJECT,ipt_state,iptable_filter
dm_mirror              22677  0
dm_mod                 57181  1 dm_mirror
video                  16197  0
button                  6609  0
battery                 9541  0
ac                      4933  0
ipv6                  248737  14
ohci1394               35849  0
ieee1394              297625  1 ohci1394
usblp                  13633  0
uhci_hcd               32465  0
ehci_hcd               34509  0
nvidia               3701064  14
snd_intel8x0m          17669  1
i2c_i801                9037  0
i2c_core               22209  1 i2c_i801
snd_intel8x0           32929  3
snd_ac97_codec         88765  2 snd_intel8x0m,snd_intel8x0
snd_ac97_bus            2625  1 snd_ac97_codec
snd_seq_dummy           3781  0
snd_seq_oss            31681  0
snd_seq_midi_event      7105  1 snd_seq_oss
snd_seq                49617  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          9037  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            50801  0
snd_mixer_oss          18113  4 snd_pcm_oss
snd_pcm                87621  4
snd_intel8x0m,snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              25285  2 snd_seq,snd_pcm
snd                    54565  12
snd_intel8x0m,snd_intel8x0,snd_ac97_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore               9761  4 snd
snd_page_alloc         10825  3 snd_intel8x0m,snd_intel8x0,snd_pcm
ipw2200                72073  0
ieee80211              22665  1 ipw2200
ieee80211_crypt         5701  2 ieee80211_crypt_wep,ieee80211
b44                    21829  0
mii                     5441  1 b44
ext3                  130889  3
jbd                    57941  1 ext3
ata_piix                9541  0
libata                 47181  1 ata_piix
sd_mod                 18881  0
scsi_mod              135657  2 libata,sd_mod
[rodd@localhost ~]$
Comment 3 Rodd Clarkson 2005-09-19 05:07:41 EDT
The external amplifier checkbox is NOT CHECKED by default.  I have to CHECK it.
Comment 4 Martin Stransky 2005-09-19 10:37:44 EDT
snd_intel8x0m is a driver for your software modem... The external amplifier mute
checkbox isn't checked by default, because it's enabled by default.
Comment 5 Rodd Clarkson 2005-09-19 17:26:53 EDT
Right, so did you figure out what my sound driver is from the lsmod above.

I don't know also, so I can't tell you what's on or off.  I can only report on
how things appear to me.  If a checked box means something has been turned off,
then that's fine as long as you understand this.  (Although it does seem
backwards to me).
Comment 6 Martin Stransky 2005-09-26 05:10:59 EDT
Unfortunately there is a problem with the "External amplifier". Some boxes need
it on and some need it off. People from ALSA prepare new mixer interface, so I
hope it will fix this problem....

Note You need to log in before you can comment on or make changes to this bug.