Bug 1686160 - Cluster Logging operator does not show as "Installed" when installed to a project other than default
Summary: Cluster Logging operator does not show as "Installed" when installed to a pro...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.1.0
Assignee: Evan Cordell
QA Contact: Mike Fiedler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-06 20:56 UTC by Mike Fiedler
Modified: 2019-06-04 10:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:45:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:45:10 UTC

Description Mike Fiedler 2019-03-06 20:56:56 UTC
Description of problem:

Installing the Cluster Logging operator to the openshift-logging project (which is the correct place for it) results in it never showing up in the management console as installed.   Only when it is installed to the default project does it show up as Installed

Version-Release number of selected component (if applicable): 4.0.0-0.nightly-2019-03-06-074438


How reproducible: Always


Steps to Reproduce:
0. create openshift-logging project
1. Catalog -> OperatorHub -> Cluster Logging Operator
2. Install -> choose openshift-logging



Actual results:

The operator installs and runs but there is no indication on the OperatorHub or Installed Operators page that it is installed and no way to create a clusterlogging CR from the console.

If it is installed in the default namespace it shows up in both places


Expected results:

Installing clusterlogging-operator to openshift-logging namespace results in it appearing in Installed Operators.


Additional info:

Comment 2 Evan Cordell 2019-04-01 14:42:48 UTC
This is fixed in recent releases.

Comment 4 Mike Fiedler 2019-04-03 12:09:17 UTC
Verified on 4.0.0-0.10 - clusterlogging operator installed to openshift-logging namespace and shows as "Installed" on OperatorHub

Comment 6 errata-xmlrpc 2019-06-04 10:45:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.