Bug 1686173 - cluster logging operator incorrectly sets memory and cpu limits after changes from defaults
Summary: cluster logging operator incorrectly sets memory and cpu limits after changes...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.1.0
Assignee: ewolinet
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-06 21:38 UTC by Jeff Cantrill
Modified: 2019-06-04 10:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:45:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:45:10 UTC

Description Jeff Cantrill 2019-03-06 21:38:02 UTC
Description of problem:


Version-Release number of selected component (if applicable): 4.0


How reproducible: Always


Steps to Reproduce:
1. Deploy ClusterLogging without defining resources. CLO defaults request and limit values
2. Edit ClusterLogging instance to spec resources.request.memory only

Actual results:
Component roles out with resources.{request, limit}.memory


Expected results:
Component roles out with only the resources spec'd in ClusterLogging

Additional info:
I have not tested but I assume the issue is relevant to each logging component

Comment 3 Anping Li 2019-04-01 02:41:18 UTC
The resource are changed in the CRD elasticsearch.  But the elasticsearch pod wasn't restarted.

Comment 4 ewolinet 2019-04-01 20:49:26 UTC
Is it possible you ran into https://bugzilla.redhat.com/show_bug.cgi?id=1694522?

Comment 8 errata-xmlrpc 2019-06-04 10:45:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.