Bug 168620 - update to 0.96
update to 0.96
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gwget (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thorsten Leemhuis
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-18 07:30 EDT by drago01
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-22 12:57:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for specfile update (1.16 KB, patch)
2005-09-19 12:28 EDT, drago01
no flags Details | Diff

  None (edit)
Description drago01 2005-09-18 07:30:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); de-DE; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc4 Firefox/1.0.6

Description of problem:
Can gwget in fc extras be updated to 0.96 to get large file support?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
look at the version number ;)

Additional info:
Comment 1 Thorsten Leemhuis 2005-09-18 07:57:53 EDT
Yeah, I'll look at it. You don't accidently know rpm packaging? If yes, you
could provide a patch against the current spec-file from CVS
http://cvs.fedora.redhat.com/viewcvs/rpms/gwget/?root=extras
and the update might happen faster ;-)

I lost interest in this package and don't use it anymore. I'm willing to
continue to maintain it, but it's probably better if someone who actually uses
it would do that. Are you interested? I could act as proxy for the extras-cvs if
you like.
Comment 2 drago01 2005-09-19 11:22:04 EDT
Can do this but there is a problem:
your patch (x86_64 fix) does not apply agains 0.96
Comment 3 Thorsten Leemhuis 2005-09-19 11:33:18 EDT
(In reply to comment #2)
> Can do this but there is a problem:
> your patch (x86_64 fix) does not apply agains 0.96

Just drop it, it should work fine without it now. I can test that myself and
regenerate the patch if it's still needed
Comment 4 drago01 2005-09-19 11:56:20 EDT
it fails here:
-----
gcc -Wall -Wimplicit -Wreturn-type -Wunused -Wswitch -Wcomment -Wuninitialized
-Wparentheses -Wpointer-arith -Wmissing-prototypes -O1 -g -O2 -g -pipe
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -m64 -mtune=nocona -o gwget gwget-marshal.o
GNOME_Gwget-stubs.o GNOME_Gwget-common.o GNOME_Gwget-skels.o main.o
main_window.o main_window_cb.o gwget_data.o wget-log.o utils.o
custom-cell-renderer-progressbar.o new_window.o eggtrayicon.o systray.o
gwget-application-server.o -Wl,--export-dynamic  -pthread -L/usr/X11R6/lib64
-lgnomeui-2 -lSM -lICE -lbonoboui-2 -lgnomecanvas-2 -lgnome-2
/usr/lib/libpopt.so -lart_lgpl_2 -lpangoft2-1.0 -lgnomevfs-2 -lbonobo-2
-lgconf-2 -lbonobo-activation -lORBit-2 -lgthread-2.0 -lglade-2.0 -lgtk-x11-2.0
-lxml2 -lpthread -lz -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangoxft-1.0
-lpangox-1.0 -lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0
/usr/lib/libpopt.so: could not read symbols: File in wrong format
collect2: ld returned 1 exit status
-------------------
it should link against /usr/lib64/libpopt.so
Comment 5 Thorsten Leemhuis 2005-09-19 12:09:35 EDT
(In reply to comment #4)
> it fails here:

:-|

> -----
[...]
> /usr/lib/libpopt.so: could not read symbols: File in wrong format
> collect2: ld returned 1 exit status
> -------------------
> it should link against /usr/lib64/libpopt.so

You can avoid this by uninstalling popt.i386 on your machine. In the buildsystem
only x86_64 packages are installed. Therefore is should not happen and we can
ignore it.
Comment 6 drago01 2005-09-19 12:28:07 EDT
Created attachment 118991 [details]
patch for specfile update

here is the patch.
(updated tarball is needed)
I also updated the urls in the spec files because they whent up to date
Comment 7 Thorsten Leemhuis 2005-09-22 12:57:07 EDT
build for devel and FC-4. Some other fixes and updates were needed, but thx for
the help!

Note You need to log in before you can comment on or make changes to this bug.