Bug 168625 - texdoc refers to old-fashioned file viewers
texdoc refers to old-fashioned file viewers
Status: CLOSED DUPLICATE of bug 162442
Product: Fedora
Classification: Fedora
Component: tetex (Show other bugs)
4
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-18 10:09 EDT by Mary Ellen Foster
Modified: 2013-07-02 19:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-19 07:37:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mary Ellen Foster 2005-09-18 10:09:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050915 Fedora/1.5-0.5.0.beta1 Firefox/1.4

Description of problem:
The "texdoc" shell script included as part of teTeX lets you view documentation on TeX packages if you have it installed. For example, if you have "texdoc-doc" installed, then "texdoc geometry" will pop up the documentation for the "geometry" package.

Very helpful ... except that texdoc by default refers to fairly old-fashioned document-viewing applications, some of which I suspect aren't even available for FC4 any more.

Here's the relevant configuration:
	: ${TEXDOCVIEW_dvi='(xdvi %s) &'}
	: ${TEXDOCVIEW_pdf='(xpdf %s) &'}
	: ${TEXDOCVIEW_ps='(gv %s) &'}
	: ${TEXDOCVIEW_html='(htmlview %s) 2>/dev/null || firefox %s &'}
	: ${TEXDOCVIEW_txt="${PAGER-more} %s"}
	: ${TEXDOCVIEW_="${PAGER-more} %s"} # no extension, default to pager

htmlview and the pager seem all right, but I'd dispute the choices for dvi, pdf, and ps. I only discovered this because I don't actually have xpdf installed at all. In my own KDE-centric world, I'd redefine them to kdvi, kpdf, and kghostview respectively, but I suspect that xdvi, evince, and whatever the default PostScript viewer application is would be equally good choices.

Version-Release number of selected component (if applicable):
tetex-3.0-4

How reproducible:
Always

Steps to Reproduce:
1. Try to view a piece of LaTeX documentation that's in PostScript format; e.g., "texdoc texdraw"


Actual Results:  System responds: /usr/bin/texdoc: line 193: gv: command not found

Expected Results:  It should have shown the texdraw documentation in the default PostScript viewer application.

Additional info:
Comment 1 Mary Ellen Foster 2005-09-18 13:21:07 EDT
I wrote:
> For example, if you have "texdoc-doc" installed, ...

Of course, I meant "tetex-doc" there. Doesn't really affect the bug report, but
it was bothering me.
Comment 2 Jindrich Novy 2005-09-19 07:37:40 EDT
Ok, I fixed the texdoctk defaults a while ago to fit Fedora, updates for FC4 are
comming soon.

*** This bug has been marked as a duplicate of 162442 ***

Note You need to log in before you can comment on or make changes to this bug.