Bug 1686322 - URL should be correct for changelog
Summary: URL should be correct for changelog
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: Clayton Coleman
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-07 09:28 UTC by shahan
Modified: 2019-06-04 10:45 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:45:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:45:33 UTC

Description shahan 2019-03-07 09:28:21 UTC
Description of problem:
  URL should be correct for changelog 

Version-Release number of selected component (if applicable):
4.0.0-0.nightly-2019-03-07-075403

How reproducible:
always

Steps to Reproduce:
1. oc adm release info --changes-from=registry.svc.ci.openshift.org/ocp/release:4.0.0-0.nightly-2019-03-06-074438   registry.svc.ci.openshift.org/ocp/release:4.0.0-0.nightly-2019-03-07-075403 --commits | grep cluster-storage-operator

2. open the link https://github.com/openshift/cluster-storage-operator/changes/b850242280b7ef2cf7631952229c0a438ec39e64...4cdc1e782067eacd0eed79cc886b023868498194

3.

Actual results:
2. It will get "Not found"  error.

Expected results:
2. the URL should be https://github.com/openshift/cluster-storage-operator/compare/b850242280b7ef2cf7631952229c0a438ec39e64...4cdc1e782067eacd0eed79cc886b023868498194

Additional info:

Comment 1 Liang Xia 2019-03-07 10:18:24 UTC
Proposed a PR, https://github.com/openshift/origin/pull/22265

Comment 2 Liang Xia 2019-03-08 02:28:56 UTC
https://github.com/openshift/origin/pull/22265 merged.

Comment 3 shahan 2019-03-12 08:41:18 UTC
$  oc adm release info --changes-from=registry.svc.ci.openshift.org/ocp/release:4.0.0-0.nightly-2019-03-06-074438    registry.svc.ci.openshift.org/ocp/release:4.0.0-0.nightly-2019-03-11-133421 --commits |  grep cluster-storage-operator
  cluster-storage-operator                      https://github.com/openshift/cluster-storage-operator/compare/b850242280b7ef2cf7631952229c0a438ec39e64...4cdc1e782067eacd0eed79cc886b023868498194

$ oc version
Client Version: version.Info{Major:"4", Minor:"0+", GitVersion:"v4.0.22", GitCommit:"219bbe2f0c", GitTreeState:"", BuildDate:"2019-03-10T22:23:11Z", GoVersion:"", Compiler:"", Platform:""}
Server Version: version.Info{Major:"1", Minor:"11+", GitVersion:"v1.11.0+d4cacc0", GitCommit:"d4cacc0", GitTreeState:"clean", BuildDate:"2018-10-17T03:34:44Z", GoVersion:"go1.10.3", Compiler:"gc", Platform:"linux/amd64"}

Verified this bug.

Comment 6 errata-xmlrpc 2019-06-04 10:45:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.