Bug 1686326 - Cannot boot aarch64 image due to host-only initramfs
Summary: Cannot boot aarch64 image due to host-only initramfs
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 30
Hardware: aarch64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Keywords:
Depends On:
Blocks: BetaBlocker, F30BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2019-03-07 09:37 UTC by Alessio
Modified: 2019-03-11 00:21 UTC (History)
16 users (show)

Fixed In Version: anaconda-30.25.3-3 anaconda-30.25.3-3.fc30
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2019-03-11 00:21:22 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alessio 2019-03-07 09:37:15 UTC
I don't know if dracut is the right component.

However I'm unable to boot aarch64 image on a Raspberry Pi 3
I've tested Fedora-Minimal-30-20190301.n.0.aarch64.raw.xz and the boot process hangs here:

[  OK  ] Started udev Kernel Device Manager.
[    7.817300] audit: type=1130 audit(1550658626.689:8): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=kernel msg='unit=systemd-udevd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
         Starting udev Coldplug all Devices...
         Mounting Kernel Configuration File System...
[  OK  ] Mounted Kernel Configuration File System.
[  OK  ] Started udev Coldplug all Devices.
[    8.317371] audit: type=1130 audit(1550658627.189:9): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=kernel msg='unit=systemd-udev-trigger comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
         Starting Show Plymouth Boot Screen...
[  OK  ] Reached target Remote File Systems (Pre).
[  OK  ] Reached target Remote File Systems.
[    8.917754] audit: type=1130 audit(1550658627.789:10): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=kernel msg='unit=plymouth-start comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[  OK  ] Started Show Plymouth Boot Screen.
[  OK  ] Reached target Paths.
[  OK  ] Started Forward Password R…s to Plymouth Directory Watch.
[**    ] A start job is running for /dev/d[   14.802159] random: fast init done
[ ***  ] A start jo[  268.747283] random: crng init done
[  268.756955] random: 7 urandom warning(s) missed due to ratelimiting
[***   ] A start job is running for /dev/dis…8213296b5e60 (6min 56s / no limit)

Comment 1 Paul Whalen 2019-03-07 14:27:59 UTC
The aarch64 disk images are currently being created with host-only initramfs, despite having dracut-config-generic installed. From the logs:

dracut -H --persistent-policy by-uuid -f /boot/initramfs-5.0.0-0.rc8.git0.1.fc30.aarch64.img 5.0.0-0.rc8.git0.1.fc30.aarch64

Javier was able to track this down in anaconda and submitted a PR to fix it:

https://github.com/rhinstaller/anaconda/pull/1873

Comment 2 Fedora Blocker Bugs Application 2019-03-07 14:29:47 UTC
Proposed as a Blocker for 30-beta by Fedora user pbrobinson using the blocker tracking app because:

 Raspberry Pi is a blocking device but this actually affects all ARM and aarch64 devices booting UEFI

Comment 3 Peter Robinson 2019-03-07 14:30:40 UTC
PR for fix in anaconda upstream https://github.com/rhinstaller/anaconda/pull/1873

Comment 4 Adam Williamson 2019-03-07 15:22:22 UTC
+1 blocker for me.

Comment 5 Mohan Boddu 2019-03-08 15:40:45 UTC
+1 Blocker

Comment 6 Kevin Fenzi 2019-03-08 15:49:30 UTC
+1 blocker

Comment 7 Adam Williamson 2019-03-08 16:06:04 UTC
That's +3, marking as accepted. Can we get an update, Jiri? Thanks!

Comment 8 Fedora Update System 2019-03-08 16:27:11 UTC
anaconda-30.25.3-3.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-17b42b3a9c

Comment 9 Fedora Update System 2019-03-08 19:45:32 UTC
anaconda-30.25.3-3.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-17b42b3a9c

Comment 10 Fedora Update System 2019-03-11 00:21:22 UTC
anaconda-30.25.3-3.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.