Bug 1686349 - when configure kubelet dynamically, machine-config-operator show error log
Summary: when configure kubelet dynamically, machine-config-operator show error log
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 4.1.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: Ryan Phillips
QA Contact: Sunil Choudhary
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-07 10:07 UTC by MinLi
Modified: 2019-06-04 10:45 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:45:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:45:33 UTC

Description MinLi 2019-03-07 10:07:47 UTC
Description of problem:
When configure kubelet dynamically, machine-config-operator show error log

Version-Release number of selected component (if applicable):
4.0.0-0.nightly-2019-03-04-234414
oc v4.0.0-0.182.0


How reproducible:
always

Steps to Reproduce:
1.edit machineconfigpool worker, add label"custom-kubelet: max-pods-worker"
#oc edit machineconfigpool worker
for example:
metadata:
  creationTimestamp: 2019-03-07T07:10:04Z
  generation: 1
  labels:
    custom-kubelet: max-pods-worker(add this line)
  ...

2.create a kubeletconfig cr
oc create -f worker-kube-config.yaml
yaml file as:
apiVersion: machineconfiguration.openshift.io/v1
kind: KubeletConfig
metadata:
  name: set-max-pods-worker
spec:
  machineConfigPoolSelector:
    matchLabels:
      custom-kubelet: max-pods-worker
  kubeletConfig:
    maxPods: 249

3.oc get machineconfig
generate a new machineconfig named "99-worker-74b4fa0b-4091-11e9-96ec-067bf345463e-kubelet"

4.login all worker node, check /etc/kubernetes/kubelet.conf has the kubelet configuration "maxPods: 249"

5.oc logs machine-config-controller-8cc654f5d-rlckl -n openshift-machine-config-operator | grep set-max-pods-worker

Actual results:
5.there is error log as below:
I0307 09:19:23.650843       1 kubelet_config_controller.go:412] Applied KubeletConfig set-max-pods-worker on MachineConfigPool worker
I0307 09:19:23.838860       1 kubelet_config_controller.go:245] Error syncing kubeletconfig set-max-pods-worker: Operation cannot be fulfilled on kubeletconfigs.machineconfiguration.openshift.io "set-max-pods-worker": the object has been modified; please apply your changes to the latest version and try again
I0307 09:19:24.449674       1 kubelet_config_controller.go:412] Applied KubeletConfig set-max-pods-worker on MachineConfigPool worker
E0307 09:19:24.638529       1 kubelet_config_controller.go:250] Operation cannot be fulfilled on kubeletconfigs.machineconfiguration.openshift.io "set-max-pods-worker": the object has been modified; please apply your changes to the latest version and try again
I0307 09:19:24.638564       1 kubelet_config_controller.go:251] Dropping kubeletconfig "set-max-pods-worker" out of the queue: Operation cannot be fulfilled on kubeletconfigs.machineconfiguration.openshift.io "set-max-pods-worker": the object has been modified; please apply your changes to the latest version and try again
I0307 09:19:25.254641       1 kubelet_config_controller.go:412] Applied KubeletConfig set-max-pods-worker on MachineConfigPool worker
I0307 09:19:25.438144       1 kubelet_config_controller.go:245] Error syncing kubeletconfig set-max-pods-worker: Operation cannot be fulfilled on kubeletconfigs.machineconfiguration.openshift.io "set-max-pods-worker": the object has been modified; please apply your changes to the latest version and try again
I0307 09:19:26.049979       1 kubelet_config_controller.go:412] Applied KubeletConfig set-max-pods-worker on MachineConfigPool worker
I0307 09:19:26.241090       1 kubelet_config_controller.go:245] Error syncing kubeletconfig set-max-pods-worker: Operation cannot be fulfilled on kubeletconfigs.machineconfiguration.openshift.io "set-max-pods-worker": the object has been modified; please apply your changes to the latest version and try again

Expected results:
5.there is no error log

Additional info:

Comment 2 Ryan Phillips 2019-04-01 15:22:17 UTC
PR Merged

Comment 6 errata-xmlrpc 2019-06-04 10:45:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.