Bug 168645 - PnP USB printer needs fiddle before being able to print.
PnP USB printer needs fiddle before being able to print.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: desktop-printing (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
: Reopened
Depends On:
Blocks: FC6Update
  Show dependency treegraph
 
Reported: 2005-09-18 20:17 EDT by Rodd Clarkson
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.19-21.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-16 12:53:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dialog that appears when Samsung ML1710 is plugged into USB slot. (24.02 KB, image/png)
2006-12-22 17:20 EST, Rodd Clarkson
no flags Details

  None (edit)
Description Rodd Clarkson 2005-09-18 20:17:48 EDT
Description of problem:

I've got a Samsung ML-1710 which uses the USB interface for printing.

When I plug the printer into a USB port, it appears in the Printer
Configuration, but you can't print to it.

For example:

1. Turn the printer on and then plug it into the USB port while Fedora Core
(rawhide or FC4) is on.
2. Open Desktop > System Settings > Printing.  The dialog shows a ml-1710--1,
which is not shared and is the default printer.
3. In the Printer Configuration dialog, select Test > Cups test page.

An error is displayed:

    There was a problem sending CUPS test page
    to 'ml-1710--1' queue:

    lpr: error - unable to print file: client-error-not-found

4. Close the error dialog.
5. Select the printer, and then click Edit.
6. Don't make any changes and just click OK.
7. In the printer configuration dialog, click Apply (which is not avaiable).
8. In the Printer Configuration dialog, select Test > Cups test page.

The printer now prints.

It is also avaiable for use in other applications.  Until the steps above are
preformed, the printer is not avaiable in other (gnome) applications.
Comment 1 Rodd Clarkson 2005-09-18 20:20:32 EDT
It should be noted that the gnome-print dialog doesn't actually display the
printer name until you restart the application (and I think it should), but that
you can print using the generic printer option.
Comment 2 Rodd Clarkson 2005-09-18 20:25:47 EDT
Actually, printing doesn't seem to work from evince (and moybe other places). 
The printer icon appears in the notification area, and the it goes through the
motions, but it doesn't print.

If I completely restart evince, then the printer appears and I can print using
the printer name.
Comment 3 Tim Waugh 2005-09-19 04:45:07 EDT
I think this is because cups-config-daemon is not restarting cups after adding
the printer using printconf-tui.
Comment 4 Rodd Clarkson 2005-10-06 19:51:45 EDT
this is still a problem with current rawhide builds, and I suspect you're right
in saying that cups isn't getting restarted after adding the printer.
Comment 5 Tim Waugh 2005-10-07 04:15:53 EDT
Actually I had the component wrong it seems -- fixing and reassigning.

FWIW, '/sbin/service cups reload' should be enough for this, rather than a full
restart.  The initscript regenerates the configuration files as needed.
Comment 6 Rodd Clarkson 2005-11-15 20:29:18 EST
This still hasn't been resolved.

I can confirm that using /etc/init.d/cups restart resolves the problem.

(Sorry, forgot to test reload instead of restart.)
Comment 7 Rodd Clarkson 2005-11-17 19:49:43 EST
I can confirm that a simple

    sudo /etc/init.d/cups reload

is suffice to get the printer working.
Comment 8 Stephen 2006-02-11 12:24:03 EST
I think I have the same problem.

The computer is left on over night, the printer is turned off.  Next morning
when the printer is turned on, it usually works.  Sometimes however it does not.
 When it does not, there is no error message.  /etc/init.d/cups restart solves
the problem.

Here's a snippet from /var/log/messages:

(disconnect)

Feb 10 17:21:39 d66-222-174-192 kernel: usb 4-5: USB disconnect, address 6
Feb 10 17:21:39 d66-222-174-192 kernel: drivers/usb/class/usblp.c: usblp0: removed
Feb 10 17:21:44 d66-222-174-192 kernel: usb 4-5: new high speed USB device using
ehci_hcd and address 7
Feb 10 17:21:44 d66-222-174-192 kernel: usb 4-5: configuration #1 chosen from 1
choice
Feb 10 17:21:44 d66-222-174-192 kernel: drivers/usb/class/usblp.c: usblp0: USB
Bidirectional printer dev 7 if 0 alt 0 proto 2 vid 0x413C pid 0x5602

(connect)

Feb 11 10:11:44 d66-222-174-192 kernel: usb 4-5: USB disconnect, address 7
Feb 11 10:11:44 d66-222-174-192 kernel: drivers/usb/class/usblp.c: usblp0: removed
Feb 11 10:12:02 d66-222-174-192 kernel: usb 4-5: new high speed USB device using
ehci_hcd and address 8
Feb 11 10:12:02 d66-222-174-192 kernel: usb 4-5: configuration #1 chosen from 1
choice
Feb 11 10:12:02 d66-222-174-192 kernel: drivers/usb/class/usblp.c: usblp0: USB
Bidirectional printer dev 8 if 0 alt 0 proto 2 vid 0x413C pid 0x5602
Feb 11 10:16:44 d66-222-174-192 hpiod: ParDevice::nibble_read failed:
Input/output error

(printer now works)


Printer is a new Dell 3000cn.  Latest Rawhide.  Hasn't worked since at least FC5
T1 for me.


Comment 9 Tim Waugh 2006-12-21 13:33:18 EST
hpiod: ParDevice::nibble_read failed: Input/output error

So perhaps it's an HPLIP issue of some sort?  Do you still have Fedora
installed, and if so which version are you running currently?
Comment 10 Stephen 2006-12-21 14:06:36 EST
I don't have this printer any more. Sorry...
Comment 11 Tim Waugh 2006-12-21 14:14:42 EST
Okay, sorry we didn't get to this one in time.
Comment 12 Rodd Clarkson 2006-12-22 05:53:13 EST
Okay I'm confused.  Tim Waugh asked me this question:


---------------------------------------
Tim Waugh <twaugh@redhat.com> has asked Rodd Clarkson <rodd@clarkson.id.au> for
needinfo:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=168645

------- Additional Comments from Tim Waugh <twaugh@redhat.com>
hpiod: ParDevice::nibble_read failed: Input/output error

So perhaps it's an HPLIP issue of some sort?  Do you still have Fedora
installed, and if so which version are you running currently?
---------------------------------------

but this bug is closed (WONTFIX) and I don't see this question in the comments
above.

The answer is I have access to FC 4, 5 and 6 at the moment, and I'm currently
running 6 (and have 5 on my laptop, my wife is using 4 (I think)).

Should we reopen this bug if we are lookng for answers?
Comment 13 Rodd Clarkson 2006-12-22 05:55:45 EST
Ah, I see.

The comment is further up the list (missed it the first time).

I still have my ML-1710, so maybe you might want to revisit this bug?
Comment 14 Tim Waugh 2006-12-22 06:50:58 EST
Yes please.  Presumably then you're still having problems with
hplip-1.6.10-1.fc6.4, then current update package for FC-6?
Comment 15 Rodd Clarkson 2006-12-22 17:18:45 EST
Okay, I plugged my trusty Samsung 1710 into my FC6 laptop and I got a dialog box
saying it couldn't figure out what printer driver I need and could I select one.
 Strangely, it selected the right one. (see the attached screen shot).

I've clicked OK on this dialog and nothing further happens.  No printer appears.
 Unplug and replug and you do the same thing over.  I even tried closing the
application I was trying to print from and restarting it.  No printer.  I then
looked in System > Adminstration > Printers and there was no printer showing.

I can print fine to this printer using the printer drivers supplied with FC6
using LPD.  I've got a netgear wireless print hub that shares USB printers on
the network using LPD and all I've done is manually set up a printer that prints
to the right queue on the server and it just works, so it seems strange that
pluging the same printer into my actual system wouldn't.

Oh and I'm using:

[rodd@localhost ~]$ rpm -q hplip
hplip-1.6.10-1.fc6.4
Comment 16 Rodd Clarkson 2006-12-22 17:20:35 EST
Created attachment 144315 [details]
Dialog that appears when Samsung ML1710 is plugged into USB slot.

Note the the right printer is selected by default, even though the dialog
claims it couldn't be figured out what driver to use.
Comment 17 Tim Waugh 2007-01-03 12:56:48 EST
What does 'rpm -q desktop-printing' say now?  I'm pretty sure this should be
fixed in 0.19-21.fc6.
Comment 18 Tim Waugh 2007-04-16 12:53:02 EDT
Closing.

Note You need to log in before you can comment on or make changes to this bug.