Bug 1686454 (CVE-2019-8331) - CVE-2019-8331 bootstrap: XSS in the tooltip or popover data-template attribute
Summary: CVE-2019-8331 bootstrap: XSS in the tooltip or popover data-template attribute
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2019-8331
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1686455 1686456 1686457 1686458 1692161 1692162 1692163 1692164 1740984 1692159 1692160 1740985 1753842
Blocks: 1686483
TreeView+ depends on / blocked
 
Reported: 2019-03-07 13:49 UTC by Laura Pardo
Modified: 2019-10-30 11:15 UTC (History)
16 users (show)

Fixed In Version: bootstrap 4.3.1
Doc Type: If docs needed, set a value
Doc Text:
A cross-site scripting vulnerability was discovered in bootstrap. If an attacker could control the data given to tooltip or popover, they could inject HTML or Javascript into the rendered page when tooltip or popover events fired.
Clone Of:
Environment:
Last Closed: 2019-07-12 13:06:45 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2019:1456 None None None 2019-06-11 15:32:28 UTC
Red Hat Product Errata RHSA-2019:3023 None None None 2019-10-10 15:38:50 UTC
Red Hat Product Errata RHSA-2019:3024 None None None 2019-10-10 15:38:55 UTC

Description Laura Pardo 2019-03-07 13:49:23 UTC
A vulnerability was found in Bootstrap before 4.3.1. An XSS is possible in the tooltip or popover data-template attribute.


References:
https://github.com/twbs/bootstrap/releases/tag/v4.3.1

Upstream Patch:
https://github.com/twbs/bootstrap/pull/28236

Comment 1 Laura Pardo 2019-03-07 13:49:46 UTC
Created python-XStatic-Bootstrap-SCSS tracking bugs for this issue:

Affects: epel-7 [bug 1686455]
Affects: fedora-all [bug 1686456]
Affects: openstack-rdo [bug 1686458]


Created rubygem-bootstrap-sass tracking bugs for this issue:

Affects: fedora-all [bug 1686457]

Comment 5 Nick Tait 2019-03-24 19:53:10 UTC
Red Hat OpenStack Platform versions 8, 9, 10, 13, & 14 are affected by this vulnerability.

Comment 9 errata-xmlrpc 2019-06-11 15:32:28 UTC
This issue has been addressed in the following products:

  Red Hat Single Sign-On 7.3.2 zip

Via RHSA-2019:1456 https://access.redhat.com/errata/RHSA-2019:1456

Comment 10 Product Security DevOps Team 2019-07-12 13:06:45 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2019-8331

Comment 16 Eric Christensen 2019-09-23 12:32:05 UTC
Statement:

Red Hat CloudForms 4.6 and newer versions include the vulnerable component, but there is no risk of exploitation since there is no possible vector to access the vulnerability. Older Red Hat CloudForms versions don't use the vulnerable component at all.

Comment 17 errata-xmlrpc 2019-10-10 15:38:49 UTC
This issue has been addressed in the following products:

  Red Hat Virtualization Engine 4.3

Via RHSA-2019:3023 https://access.redhat.com/errata/RHSA-2019:3023

Comment 18 errata-xmlrpc 2019-10-10 15:38:53 UTC
This issue has been addressed in the following products:

  Red Hat Virtualization Engine 4.3

Via RHSA-2019:3024 https://access.redhat.com/errata/RHSA-2019:3024


Note You need to log in before you can comment on or make changes to this bug.