Bug 1686621 - openstack tripleo container image prepare default doesn't provide downstream values for OpenShift related parameters
Summary: openstack tripleo container image prepare default doesn't provide downstream ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: beta
: 15.0 (Stein)
Assignee: Martin André
QA Contact: Marius Cornea
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-07 21:27 UTC by Marius Cornea
Modified: 2019-10-23 06:39 UTC (History)
6 users (show)

Fixed In Version: openstack-tripleo-common-10.4.1-0.20190313060345.1377727.el8ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:20:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:20:47 UTC

Description Marius Cornea 2019-03-07 21:27:51 UTC
Description of problem:

parameter_defaults:
  ContainerImagePrepare:
  - set:
      ceph_image: rhceph-3-rhel7
      ceph_namespace: registry.access.redhat.com/rhceph
      ceph_tag: latest
      name_prefix: openstack-
      name_suffix: ''
      namespace: registry.access.redhat.com/rhosp15
      neutron_driver: null
      openshift_asb_namespace: docker.io/ansibleplaybookbundle
      openshift_asb_tag: latest
      openshift_cluster_monitoring_image: cluster-monitoring-operator
      openshift_cluster_monitoring_namespace: quay.io/coreos
      openshift_cluster_monitoring_tag: v0.1.1
      openshift_cockpit_image: kubernetes
      openshift_cockpit_namespace: docker.io/cockpit
      openshift_cockpit_tag: latest
      openshift_configmap_reload_image: configmap-reload
      openshift_configmap_reload_namespace: quay.io/coreos
      openshift_configmap_reload_tag: v0.0.1
      openshift_etcd_image: etcd
      openshift_etcd_namespace: registry.fedoraproject.org/latest
      openshift_etcd_tag: latest
      openshift_gluster_block_image: glusterblock-provisioner
      openshift_gluster_image: gluster-centos
      openshift_gluster_namespace: docker.io/gluster
      openshift_gluster_tag: latest
      openshift_grafana_namespace: docker.io/grafana
      openshift_grafana_tag: 5.2.1
      openshift_heketi_image: heketi
      openshift_heketi_namespace: docker.io/heketi
      openshift_heketi_tag: latest
      openshift_kube_rbac_proxy_image: kube-rbac-proxy
      openshift_kube_rbac_proxy_namespace: quay.io/coreos
      openshift_kube_rbac_proxy_tag: v0.3.1
      openshift_kube_state_metrics_image: kube-state-metrics
      openshift_kube_state_metrics_namespace: quay.io/coreos
      openshift_kube_state_metrics_tag: v1.3.1
      openshift_namespace: docker.io/openshift
      openshift_oauth_proxy_tag: v1.1.0
      openshift_prefix: origin
      openshift_prometheus_alertmanager_tag: v0.15.2
      openshift_prometheus_config_reload_image: prometheus-config-reloader
      openshift_prometheus_config_reload_namespace: quay.io/coreos
      openshift_prometheus_config_reload_tag: v0.23.2
      openshift_prometheus_node_exporter_tag: v0.16.0
      openshift_prometheus_operator_image: prometheus-operator
      openshift_prometheus_operator_namespace: quay.io/coreos
      openshift_prometheus_operator_tag: v0.23.2
      openshift_prometheus_tag: v2.3.2
      openshift_tag: v3.11.0
      tag: 15.0
    tag_from_label: '{version}-{release}'


Version-Release number of selected component (if applicable):
openstack-tripleo-common-containers-10.4.1-0.20190307101113.2300a22.el8ost.noarch
python3-tripleo-common-10.4.1-0.20190307101113.2300a22.el8ost.noarch
openstack-tripleo-common-10.4.1-0.20190307101113.2300a22.el8ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy OSP15 undercloud
2. openstack tripleo container image prepare default

Actual results:
OpenShift parameters use docker.io

Expected results:
OpenShift parameters use registry.redhat.com

Additional info:

Comment 2 Martin André 2019-05-17 11:31:35 UTC
Removing the blocker flag as this goes away in OSP15.

Comment 8 errata-xmlrpc 2019-09-21 11:20:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.