Bug 1686765 - The elasticsearch configmap should be changed when EO in Unmanaged status
Summary: The elasticsearch configmap should be changed when EO in Unmanaged status
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: ewolinet
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-08 09:41 UTC by Anping Li
Modified: 2019-06-04 10:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:45:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:45:26 UTC

Description Anping Li 2019-03-08 09:41:31 UTC
Description of problem:
The changes in  configmap/elasticsearch is still overwriten when EO in Unmanaged status


Version-Release number of the following components:
quay.io/openshift/origin-elasticsearch-operator@sha256:8cb64487f29ad1f8cb0a6a697ea935d74f923bfd4c8b37b88116c7ce35f5b234

How reproducible:
always

Steps to Reproduce:
1. set managementState: Unmanaged  in CRs elasticsearch
2. set openshift.kibana.index.mode: shared_non_ops in configmap/elasticsearch
3. Waiting for while, check the openshift.kibana.index.mode  again


Actual results:
openshift.kibana.index.mode turn back to shared_ops

Expected results:
openshift.kibana.index.mode shared_non_ops

Comment 2 Qiaoling Tang 2019-03-21 05:25:04 UTC
Elasticsearch cm can be changed when "managementState: Unmanaged" set in elasticsearch CR.

Comment 4 errata-xmlrpc 2019-06-04 10:45:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.