Bug 168678 - 6.8.2-1.FC3.45 X server refuses to start 2nd ati head in multi-head display
6.8.2-1.FC3.45 X server refuses to start 2nd ati head in multi-head display
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-19 10:14 EDT by Todd Allen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-17 19:45:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -vv (8.88 KB, text/plain)
2005-09-19 10:14 EDT, Todd Allen
no flags Details
/var/log/Xorg.0.log with 6.8.2-1.FC3.13 (which works) (70.18 KB, text/plain)
2005-09-19 10:16 EDT, Todd Allen
no flags Details
/var/log/Xorg.0.log with 6.8.2-1.FC3.45 (which fails) (60.84 KB, text/plain)
2005-09-19 10:17 EDT, Todd Allen
no flags Details
/etc/X11/xorg.conf (3.34 KB, text/plain)
2005-09-19 10:39 EDT, Todd Allen
no flags Details
/var/log/Xorg.0.log with 6.8.2-1.FC3.45 with "nolinear" (fails) (60.70 KB, text/plain)
2005-09-19 10:41 EDT, Todd Allen
no flags Details
/var/log/Xorg.0.log with 6.8.2-1.FC3.45 with no "dri" (still fails) (60.36 KB, text/plain)
2005-09-19 10:42 EDT, Todd Allen
no flags Details
/var/log/Xorg.0.log with 6.8.2-1.FC3.45 with "nolinear" and no "dri" (still fails) (60.41 KB, text/plain)
2005-09-19 10:43 EDT, Todd Allen
no flags Details
/var/log/Xorg.0.log with 6.8.2-1.FC3.45.1 (88.00 KB, text/plain)
2005-09-21 11:32 EDT, Todd Allen
no flags Details

  None (edit)
Description Todd Allen 2005-09-19 10:14:59 EDT
Description of problem:
xorg-x11 refuses to use 2nd display in multi-head display.  The second display
uses the ati driver and is an "ATI Technologies Inc Rage XL (rev 27)".  This is
a regression.  It worked fine with xorg-x11-6.8.2-1.FC3.13.  It stopped working
with xorg-x11-6.8.2-1.FC3.45.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-1.FC3.45

How reproducible:
Always

Steps to Reproduce:
1. Boot system.
2.
3.
  
Actual results:
xdm will start X server, but will use only main head and not 2nd one.

Expected results:
X server should use both heads.

Additional info:
I will attach copies of some logs.
Comment 1 Todd Allen 2005-09-19 10:14:59 EDT
Created attachment 118978 [details]
lspci -vv
Comment 2 Todd Allen 2005-09-19 10:16:14 EDT
Created attachment 118979 [details]
/var/log/Xorg.0.log with 6.8.2-1.FC3.13 (which works)
Comment 3 Todd Allen 2005-09-19 10:17:18 EDT
Created attachment 118980 [details]
/var/log/Xorg.0.log with 6.8.2-1.FC3.45 (which fails)
Comment 4 Todd Allen 2005-09-19 10:39:44 EDT
Created attachment 118981 [details]
/etc/X11/xorg.conf
Comment 5 Todd Allen 2005-09-19 10:41:35 EDT
Created attachment 118983 [details]
/var/log/Xorg.0.log with 6.8.2-1.FC3.45 with "nolinear" (fails)

I tried adding Option "nolinear" to the "Device" section for "ATI".  It still
failed, but in this new & different way.
Comment 6 Todd Allen 2005-09-19 10:42:43 EDT
Created attachment 118984 [details]
/var/log/Xorg.0.log with 6.8.2-1.FC3.45 with no "dri" (still fails)

I noticed that this latest updated involved changes to DRI for the "ati"
driver, so I tried removing the Load "dri" line.  But it didn't help.  Here's
the output from that.
Comment 7 Todd Allen 2005-09-19 10:43:44 EDT
Created attachment 118985 [details]
/var/log/Xorg.0.log with 6.8.2-1.FC3.45 with "nolinear" and no "dri" (still fails)

To round things out, I tried both Option "nolinear" and removing Load "dri". 
It still failed.
Comment 8 Mike A. Harris 2005-09-19 22:45:16 EDT
This is probably a duplicate of bug #168752 but with different symptoms.
Since it is slightly different symptoms, we'll track it as a separate issue
for now until we gather more details.

Please test the rpm packages located at the following URL, and provide a
status update as to wether or not they change things for you or not.

    http://people.redhat.com/krh/xorg-x11/fc4

Setting status to "NEEDINFO_REPORTER", and awaiting results of testing.
Comment 9 Mike A. Harris 2005-09-19 22:45:57 EDT
Oops, I gave you the FC4 test URL.  Here is the FC3 one:

    http://people.redhat.com/krh/xorg-x11/fc3
Comment 10 Todd Allen 2005-09-21 11:32:56 EDT
Created attachment 119081 [details]
/var/log/Xorg.0.log with 6.8.2-1.FC3.45.1

With the new rpm's you mention, the X server is using the 2nd head just fine
again.	Also, from the official Fedora Core updates, I downloaded rpm's with
the same version number, but different checksums, and they work equally well.

I'm attaching the log of the successful startup with these new rpm's.

Note You need to log in before you can comment on or make changes to this bug.