Bug 168682 - can't create ChangeLog entry for a field
can't create ChangeLog entry for a field
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse-changelog (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Igor Foox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-19 10:59 EDT by Tom Tromey
Modified: 2014-08-11 01:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-23 15:47:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch (863 bytes, patch)
2006-05-19 13:08 EDT, Kyu Lee
no flags Details | Diff

  None (edit)
Description Tom Tromey 2005-09-19 10:59:39 EDT
If I put my cursor on a field and type M-C-a, I expect
a ChangeLog entry for the field to be created.  However,
instead I only get the file name and not the field name.
Comment 1 Phil Muldoon 2005-09-19 11:27:20 EDT
Can you drop a quick code snippet of the code the caret would be on when you
invoke the ChangeLog plug-in (just the code in context would be great), and the
expected ChangeLog entry from that (don't worry about author/date fields).

FWIW if the AST interrogation provides nothing, or something nonsensical, it
will strip it and the brackets and just include the filename. So it looks like
confusion on interrogating that particular language's AST model.
Comment 2 Tom Tromey 2005-09-19 11:30:24 EDT
Suppose you have a field definition like this:

  private static final long serialVersionUID = 0L;

I would expect the same ChangeLog result no matter where on the line
(at least, anywhere before the ";") the cursor appears, namely:

  * filename.java (serialVersionUID): <cursor here>

Right now I just see:

  * filename.java:
Comment 3 Kyu Lee 2006-05-19 13:08:39 EDT
Created attachment 129608 [details]
Patch
Comment 4 Kyu Lee 2006-05-19 13:10:08 EDT
I've fixed the bug, it should work now.

2006-05-19  Kyu Lee  <klee@redhat.com>

	* src/com/redhat/eclipse/changelog/core/parsers/JavaParser.java 
	(parseCurrentFunction): Fixed bug 168682.

Comment 5 Andrew Overholt 2006-05-23 14:57:38 EDT
I've applied this patch to CVS.  Thanks, Kyu.

Igor:  when you get a chance to spin a new release, can you close this bug?  Thanks.
Comment 6 Igor Foox 2006-05-23 15:47:06 EDT
I built 2.0.4 into dist-fc5-updates.
Comment 7 Andrew Overholt 2006-05-23 15:49:01 EDT
(In reply to comment #6)
> I built 2.0.4 into dist-fc5-updates.

Thanks, Igor.  Can you also build it into rawhide?
Comment 8 Igor Foox 2006-05-23 16:28:40 EDT
(In reply to comment #7)
> (In reply to comment #6)
> > I built 2.0.4 into dist-fc5-updates.
> 
> Thanks, Igor.  Can you also build it into rawhide?

Done.

Note You need to log in before you can comment on or make changes to this bug.