Bug 1686945 - Modern Fedora and RHEL8 beta need config_opts['use_bootstrap_container'] = True
Summary: Modern Fedora and RHEL8 beta need config_opts['use_bootstrap_container'] = True
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: mock
Version: epel7
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Pavel Raiskup
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-08 17:36 UTC by Pat Riehecky
Modified: 2020-05-05 07:17 UTC (History)
11 users (show)

Fixed In Version: mock-2.2-1.fc32 mock-2.2-1.fc31 mock-2.2-1.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-07 05:05:00 UTC
Type: Bug


Attachments (Terms of Use)

Description Pat Riehecky 2019-03-08 17:36:48 UTC
Description of problem:
When using mock on an EL7 host and trying to build a Fedora 28+ chroot, the config needs to add config_opts['use_bootstrap_container'] = True


Version-Release number of selected component (if applicable):
mock-1.4.14-2.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1.Install mock on an EL7 system
2.mock -r rhelbeta-8-x86_64 --init


Actual results:
fails due to new RPM features

Expected results:
Enable the bootstrap container by default for those profiles in EPEL7

Additional info:

Comment 1 Miroslav Suchý 2019-03-11 13:21:15 UTC
Yes, that is true. But the solution is not easy - it will be either pain to maintain or very hard to code. The great approach - to use host configs is discussed here: https://github.com/rpm-software-management/mock/issues/199

Comment 2 Pat Riehecky 2019-03-12 14:23:36 UTC
I was thinking a fairly simple %if within the specfile.... something like

%if 0%{?rhel} < 8
echo "config_opts['use_bootstrap_container'] = True" >> fedora_whatever_.cfg
%endif

That should keep the maintenance fairly low and provide the expected behavior.

Comment 3 Nico Kadel-Garcia 2019-07-07 18:14:23 UTC
I agree that a small loop in the .spec file is suitable. But since the problem is not merely fedora, but will also occur with rhel-8 and centos-8, it's safer to test for the "package_manager" line being "dnf" and edit the file to reset use_bootstrap_container accordingly.

Piping options into the end of the .cfg file is confusing, because this starts putting options after the "yum" stanza. Definitely put it with the

Comment 4 Nico Kadel-Garcia 2019-07-07 18:19:35 UTC
Note that the spec file in question is the mock-core-config.spec file. And I meant to say:

Definitely put it in all the /etc/mock/*.cfg file with the "package_manager" set to "dnf". This will also et the rhel-8 and other dnf based configs as they are published.

Comment 5 Fedora Admin XMLRPC Client 2020-03-17 04:43:22 UTC
This package has changed maintainer in the Fedora.
Reassigning to the new maintainer of this component.

Comment 6 Fedora Update System 2020-04-01 08:24:42 UTC
FEDORA-EPEL-2020-88ef4b4d66 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-88ef4b4d66

Comment 7 Fedora Update System 2020-04-02 07:48:04 UTC
FEDORA-2020-fba9845e22 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-fba9845e22

Comment 8 Fedora Update System 2020-04-02 07:49:15 UTC
FEDORA-2020-6b7c342fb4 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-6b7c342fb4

Comment 9 Fedora Update System 2020-04-02 07:49:42 UTC
FEDORA-2020-85df0014c1 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-85df0014c1

Comment 10 Fedora Update System 2020-04-02 07:54:42 UTC
FEDORA-EPEL-2020-88ef4b4d66 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-88ef4b4d66

Comment 11 Fedora Update System 2020-04-03 19:56:03 UTC
FEDORA-2020-fba9845e22 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-fba9845e22`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-fba9845e22

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2020-04-03 20:35:03 UTC
FEDORA-2020-85df0014c1 has been pushed to the Fedora 30 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-85df0014c1`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-85df0014c1

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Fedora Update System 2020-04-03 20:49:33 UTC
FEDORA-2020-6b7c342fb4 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-6b7c342fb4`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-6b7c342fb4

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2020-04-03 21:18:12 UTC
FEDORA-EPEL-2020-88ef4b4d66 has been pushed to the Fedora EPEL 7 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-88ef4b4d66

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 15 Fedora Update System 2020-04-07 05:05:00 UTC
FEDORA-2020-fba9845e22 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 16 Fedora Update System 2020-04-07 13:15:58 UTC
FEDORA-2020-fba9845e22 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 17 Fedora Update System 2020-04-20 22:14:44 UTC
FEDORA-2020-6b7c342fb4 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 18 Fedora Update System 2020-04-20 22:31:56 UTC
FEDORA-2020-85df0014c1 has been pushed to the Fedora 30 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 19 Fedora Update System 2020-05-05 07:17:14 UTC
FEDORA-EPEL-2020-88ef4b4d66 has been pushed to the Fedora EPEL 7 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.