Bug 1687015 - "dnf download --source" fails to download SRPM
Summary: "dnf download --source" fails to download SRPM
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Mracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-08 21:39 UTC by Ken Dreyer (Red Hat)
Modified: 2019-03-21 14:40 UTC (History)
8 users (show)

Fixed In Version: dnf-plugins-core-4.0.6-1.fc30 dnf-plugins-core-4.0.6-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-19 19:38:42 UTC
Type: Bug


Attachments (Terms of Use)

Description Ken Dreyer (Red Hat) 2019-03-08 21:39:38 UTC
Description of problem:
"dnf download --source" fails to download a source package.

Version-Release number of selected component (if applicable):
dnf-plugins-core-4.0.4-1.fc29

How reproducible:
always

Steps to Reproduce:
1. dnf install dnf-plugins-core
2. Run this download command for any source package, for example "coreutils":

dnf --disablerepo='*' --repofrompath srpms,https://dl.fedoraproject.org/pub/fedora/linux/releases/29/Server/source/tree/ download --source coreutils


Actual results:
DNF output:

  Added srpms repo from https://dl.fedoraproject.org/pub/fedora/linux/releases/29/Server/source/tree/
  Last metadata expiration check: 0:00:06 ago on Fri 08 Mar 2019 03:31:21 PM CST.
  No package coreutils available.
  Exiting due to strict setting.
  Error: No package coreutils available.

Expected results:
dnf downloads the Fedora coreutils SRPM to the current working directory.

Additional info:
I can reproduce this for any repository that only contains SRPMs (eg. the SRPM repositories for ceph.com).

RHEL 8's dnf-plugins-core-4.0.2.2-3.el8 works fine with this exact same command, so maybe there is a regression in Fedora 29.

Comment 1 Jaroslav Mracek 2019-03-09 11:04:29 UTC
I believe that the issue is fixed by https://github.com/rpm-software-management/dnf-plugins-core/commit/fe9b836c56da99ea028d67562bc5fa77c9faabcb. Please could you confirm that the issue is solved with the upstream dnf-plugins-core, that is available from our nightly repo (dnf copr enable rpmsoftwaremanagement/dnf-nightly).

Comment 2 Ken Dreyer (Red Hat) 2019-03-11 16:09:41 UTC
dnf-plugins-core-4.0.6-0.8g40ddde3.fc29 works! Thanks.

Comment 3 Fedora Update System 2019-03-13 13:41:50 UTC
dnf-plugins-core-4.0.6-1.fc29 libdnf-0.28.0-1.fc29 libcomps-0.1.11-1.fc29 createrepo_c-0.12.2-1.fc29 librepo-1.9.5-1.fc29 dnf-4.2.1-1.fc29 dnf-plugins-extras-4.0.4-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-a03be2cebe

Comment 4 Fedora Update System 2019-03-13 13:42:44 UTC
dnf-plugins-core-4.0.6-1.fc30 libdnf-0.28.0-1.fc30 libcomps-0.1.11-1.fc30 createrepo_c-0.12.2-1.fc30 librepo-1.9.5-1.fc30 dnf-4.2.1-1.fc30 dnf-plugins-extras-4.0.4-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-bc9607a8dc

Comment 5 Fedora Update System 2019-03-13 15:37:03 UTC
createrepo_c-0.12.2-1.fc30, dnf-4.2.1-1.fc30, dnf-plugins-core-4.0.6-1.fc30, dnf-plugins-extras-4.0.4-1.fc30, libcomps-0.1.11-1.fc30, libdnf-0.28.0-1.fc30, librepo-1.9.5-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-bc9607a8dc

Comment 6 Fedora Update System 2019-03-14 18:51:33 UTC
createrepo_c-0.12.2-1.fc29, dnf-4.2.1-1.fc29, dnf-plugins-core-4.0.6-1.fc29, dnf-plugins-extras-4.0.4-1.fc29, libcomps-0.1.11-1.fc29, libdnf-0.28.0-1.fc29, librepo-1.9.5-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-a03be2cebe

Comment 7 Fedora Update System 2019-03-15 13:09:36 UTC
createrepo_c-0.12.2-1.fc30 dnf-4.2.1-1.fc30 dnf-plugins-core-4.0.6-1.fc30 dnf-plugins-extras-4.0.4-1.fc30 libcomps-0.1.11-1.fc30 libdnf-0.28.0-1.fc30 librepo-1.9.5-1.fc30 swid-tools-0.7.3-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-bc9607a8dc

Comment 8 Fedora Update System 2019-03-16 20:17:32 UTC
createrepo_c-0.12.2-1.fc30, dnf-4.2.1-1.fc30, dnf-plugins-core-4.0.6-1.fc30, dnf-plugins-extras-4.0.4-1.fc30, libcomps-0.1.11-1.fc30, libdnf-0.28.0-1.fc30, librepo-1.9.5-1.fc30, swid-tools-0.7.3-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-bc9607a8dc

Comment 9 Fedora Update System 2019-03-19 19:38:42 UTC
createrepo_c-0.12.2-1.fc30, dnf-4.2.1-1.fc30, dnf-plugins-core-4.0.6-1.fc30, dnf-plugins-extras-4.0.4-1.fc30, libcomps-0.1.11-1.fc30, libdnf-0.28.0-1.fc30, librepo-1.9.5-1.fc30, swid-tools-0.7.3-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2019-03-20 22:13:03 UTC
createrepo_c-0.12.2-1.fc29, dnf-4.2.1-1.fc29, dnf-plugins-core-4.0.6-1.fc29, dnf-plugins-extras-4.0.4-1.fc29, libcomps-0.1.11-1.fc29, libdnf-0.28.0-1.fc29, librepo-1.9.5-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2019-03-21 14:40:40 UTC
createrepo_c-0.12.2-1.fc29, dnf-4.2.1-1.fc29, dnf-plugins-core-4.0.6-1.fc29, dnf-plugins-extras-4.0.4-1.fc29, libcomps-0.1.11-1.fc29, libdnf-0.28.0-1.fc29, librepo-1.9.5-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.