Bug 1687096 - Wayland: Autocompletion does only work on primary screen (GTK?)
Summary: Wayland: Autocompletion does only work on primary screen (GTK?)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: homebank
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Filipe Rosset
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-09 18:14 UTC by rugk
Modified: 2019-06-11 00:33 UTC (History)
4 users (show)

Fixed In Version: homebank-5.2.5-1.fc30 homebank-5.2.5-1.fc28 homebank-5.2.5-1.fc29 homebank-5.2.6-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-26 01:03:51 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1645099 None None None 2019-03-09 18:14:56 UTC
Launchpad 1810996 None None None 2019-03-09 18:14:56 UTC

Description rugk 2019-03-09 18:14:57 UTC
Description of problem: 
See https://bugs.launchpad.net/homebank/+bug/1810996
See https://bugs.launchpad.net/homebank/+bug/1645099

STR:
0. Have two monitors/screens.
1. Open window to add a new transaction.
2. When it is on the main screen: It shows you suggestions for the fields, where this is possible when you type in them.
3. When you move it to the secondary screen, it does not show these suggestions anymore if you type them. You can still write as usual and select them manually via the dropdown, but the autocompletion does not work.

Version-Release number of selected component (if applicable): 5.2.2


How reproducible: Usually.

---

Upstream considers it a GTK+ bug.
It also seems to be Wayland-specific.

Comment 1 Fedora Update System 2019-05-12 23:40:09 UTC
homebank-5.2.5-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-9090beda81

Comment 2 Fedora Update System 2019-05-12 23:40:16 UTC
homebank-5.2.5-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-4d13d7d027

Comment 3 Fedora Update System 2019-05-12 23:40:22 UTC
homebank-5.2.5-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-3dc14c1899

Comment 4 Fedora Update System 2019-05-12 23:40:28 UTC
homebank-5.2.5-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-4449c60419

Comment 5 Fedora Update System 2019-05-13 02:24:46 UTC
homebank-5.2.5-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-3dc14c1899

Comment 6 Fedora Update System 2019-05-13 02:29:34 UTC
homebank-5.2.5-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-4d13d7d027

Comment 7 Fedora Update System 2019-05-13 04:33:41 UTC
homebank-5.2.5-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-4449c60419

Comment 8 Fedora Update System 2019-05-13 09:53:44 UTC
homebank-5.2.5-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-9090beda81

Comment 9 Filipe Rosset 2019-05-20 03:22:13 UTC
(In reply to rugk from comment #0)
> Description of problem: 
> See https://bugs.launchpad.net/homebank/+bug/1810996
> See https://bugs.launchpad.net/homebank/+bug/1645099
> 
> STR:
> 0. Have two monitors/screens.
> 1. Open window to add a new transaction.
> 2. When it is on the main screen: It shows you suggestions for the fields,
> where this is possible when you type in them.
> 3. When you move it to the secondary screen, it does not show these
> suggestions anymore if you type them. You can still write as usual and
> select them manually via the dropdown, but the autocompletion does not work.
> 
> Version-Release number of selected component (if applicable): 5.2.2
> 
> 
> How reproducible: Usually.
> 
> ---
> 
> Upstream considers it a GTK+ bug.
> It also seems to be Wayland-specific.

I'm not going to support apps running over Wayland, until Xfce supports it.

Comment 10 Fedora Update System 2019-05-25 11:12:32 UTC
homebank-5.2.6-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-491181e1d0

Comment 11 Fedora Update System 2019-05-26 00:36:09 UTC
homebank-5.2.6-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-491181e1d0

Comment 12 Fedora Update System 2019-05-26 01:03:51 UTC
homebank-5.2.5-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2019-05-26 03:35:36 UTC
homebank-5.2.5-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2019-05-26 11:54:21 UTC
homebank-5.2.5-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2019-06-11 00:33:57 UTC
homebank-5.2.6-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.