Bug 1687135 - DNF does not error out on wrong repoquery constructions
Summary: DNF does not error out on wrong repoquery constructions
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Mracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-10 08:02 UTC by Igor Gnatenko
Modified: 2019-03-31 03:00 UTC (History)
9 users (show)

Fixed In Version: dnf-4.2.2-1.fc30 dnf-4.2.2-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-31 00:04:15 UTC


Attachments (Terms of Use)

Description Igor Gnatenko 2019-03-10 08:02:59 UTC
Description of problem:
sudo dnf repoquery --whatprovides '(crate(pkg-config/default)' returns basically all rawhide packages. But in reality this is not valid dependency construction.

Version-Release number of selected component (if applicable):
dnf-4.1.0-1.fc30.noarch
libdnf-0.26.0-2.fc30.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. sudo dnf repoquery --whatprovides '(crate(pkg-config/default)'

Actual results:
Returns 58294 packages on current rawhide system.

Expected results:
Returns an error that dependency is invalid.

Additional info:
Note '(' at the beginning of a string.

Comment 1 Jaroslav Mracek 2019-03-11 13:21:50 UTC
I create a patch (https://github.com/rpm-software-management/libdnf/pull/696) that fix the issue. In case that incorrect string is used, it returns an empty list. I decided to not raise an error, because it is an unexpected behavior from repoquery command.

Comment 2 Fedora Update System 2019-03-27 13:37:24 UTC
dnf-4.2.2-1.fc30 librepo-1.9.6-1.fc30 libdnf-0.28.1-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-b504d6ad8f

Comment 3 Fedora Update System 2019-03-27 13:37:49 UTC
dnf-4.2.2-1.fc29 librepo-1.9.6-1.fc29 libdnf-0.28.1-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-7fbfa37585

Comment 4 Fedora Update System 2019-03-27 18:18:30 UTC
dnf-4.2.2-1.fc30, libdnf-0.28.1-1.fc30, librepo-1.9.6-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-b504d6ad8f

Comment 5 Fedora Update System 2019-03-27 20:02:00 UTC
dnf-4.2.2-1.fc29, libdnf-0.28.1-1.fc29, librepo-1.9.6-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-7fbfa37585

Comment 6 Fedora Update System 2019-03-31 00:04:15 UTC
dnf-4.2.2-1.fc30, libdnf-0.28.1-1.fc30, librepo-1.9.6-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2019-03-31 03:00:49 UTC
dnf-4.2.2-1.fc29, libdnf-0.28.1-1.fc29, librepo-1.9.6-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.