Bug 168717 - pci-config space patch causes regression with Intel driver
pci-config space patch causes regression with Intel driver
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
: Regression
Depends On:
Blocks: 145411 156322
  Show dependency treegraph
 
Reported: 2005-09-19 14:25 EDT by Chris Lee
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2005-500
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 10:34:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Lee 2005-09-19 14:25:28 EDT
Description of problem:
The latest errata-candidate packages break the Intel driver. X attempts to start
and fails; the logs indicate that the system can't find the card's VideoRAM.


Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-1.EL.13.2


How reproducible:
Always.


Steps to Reproduce:
1. Install errata-candidate xorg-x11 packages on a system with an Intel chipset.
2. Launch X.
3. View X debug output.

Actual results:
X fails to launch and spews errors to the terminal.


Expected results:
X should launch and work properly.
Comment 1 Chris Lee 2005-09-19 14:51:50 EDT
Oops. Correct package version is xorg-x11-6.8.2-1.EL.13.19, not 13.12.
Comment 2 Mike A. Harris 2005-09-19 17:43:17 EDT
Kristian has investigated this, and is building new packages.
Comment 3 Jay Turner 2005-09-21 14:23:40 EDT
Looks like the 13.20 packages fix the issue on the Intel-based machine I was
reproducing on.
Comment 4 Fedora Update System 2005-09-22 00:35:00 EDT
From User-Agent: XML-RPC

xorg-x11-6.8.2-37.FC4.49.2 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 5 Luis 2005-09-22 06:44:33 EDT
I had the same problem with Fedora Core 3 with the update xorg-x11-6.8.2-1.FC3.45

With the last update xorg-x11-6.8.2-1.FC3.45.1 I have recovered the X system but
not all the functionality.

Namely, I have a dell 500m laptop and with previous packages I could close the
laptop with the computer on, leaving the screen off and later I was able to wake
up the screen passing to a console and then to the X system (this trick might
mean that the woke up was not as clean as should). With the latest package the
screen does no more wake up.
Comment 6 Mattias Ellert 2005-10-02 01:04:43 EDT
I have the same problem (the screen does not wake up when I open the lid) on my
Dell latitude D505 laptop running FC3 and xorg-x11-6.8.2-1.FC3.45.2. I used to
be able to wake it up by first switching to a text terminal (pressing
alt-ctrl-1) and then switch back to X (pressing alt-ctrl-7), so it was not
perfect before either since it did not wake up automatically. But now this trick
doesn't work either.
Comment 7 Red Hat Bugzilla 2005-10-05 10:34:39 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-500.html

Note You need to log in before you can comment on or make changes to this bug.