Bug 168720 - Illegal char '-' in release, query of specfile failed
Illegal char '-' in release, query of specfile failed
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-19 15:04 EDT by Zing
Modified: 2015-01-04 17:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-23 16:04:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zing 2005-09-19 15:04:52 EDT
Description of problem:

At some point an "@`hostname -s`" was added to the kernel-2.6.spec.  Some of my
build scripts fail because i have dashes on certain hosts and this error is
returned:

$ rpm --qf '%{N}\n' -q --specfile kernel-2.6.spec
error: line 148: Illegal char '-' in release: Release: 1.1376_FC3.zing@woot-gw
error: query of specfile kernel-2.6.spec failed, can't parse

I guess this is more of a wishlist than anything.  I'm not sure of the
repercussions of the dash, but rpm doesn't seem to like it and I change the
release names locally here anyway.


How reproducible:
always

Steps to Reproduce:
0. verify hostname has a dash in it. ex. "server-gw"
1. install a recent kernel srpm
2. run "rpm --qf '%{N}\n' -q --specfile kernel-2.6.spec"
  
Actual results:
get error about illegal char '-' in release

Expected results:
no error
Comment 1 Dave Jones 2005-09-21 22:38:07 EDT
fixed in kernel in updates-testing
Comment 2 Zing 2005-09-22 10:57:44 EDT
thanks, works for me.

Note You need to log in before you can comment on or make changes to this bug.