Bug 1687264 - Could not install katello-host-tools-tracer on rhel 8 : nothing provides python3-beautifulsoup4, python3-psutil needed by python3-tracer
Summary: Could not install katello-host-tools-tracer on rhel 8 : nothing provides pyth...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Packaging
Version: 6.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Released
Assignee: Evgeni Golov
QA Contact: Nikhil Kathole
URL:
Whiteboard:
Depends On:
Blocks: 1643130
TreeView+ depends on / blocked
 
Reported: 2019-03-11 06:31 UTC by Nikhil Kathole
Modified: 2019-10-07 17:17 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-14 12:40:29 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2019:1222 None None None 2019-05-14 12:40:36 UTC

Description Nikhil Kathole 2019-03-11 06:31:55 UTC
Description of problem:
Could not install katello-host-tools-tracer on rhel 8 : nothing provides python3-beautifulsoup4, python3-psutil needed by python3-tracer

# yum -y install katello-host-tools-tracer
Updating Subscription Management repositories.
rhel8appstream                                                                                                     93 kB/s | 2.9 kB     00:00    
rhel8baseos                                                                                                        97 kB/s | 2.9 kB     00:00    
rhel 8 x86                                                                                                         82 kB/s | 2.5 kB     00:00    
Error: 
 Problem: package katello-host-tools-tracer-3.4.2-2.el8sat.noarch requires python3-tracer, but none of the providers can be installed
  - conflicting requests
  - nothing provides python3-beautifulsoup4 needed by python3-tracer-0.7.1-1.el8sat.noarch
  - nothing provides python3-psutil needed by python3-tracer-0.7.1-1.el8sat.noarch
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)



Version-Release number of selected component (if applicable):
Satellite 6.5 snap 19


How reproducible: always


Steps to Reproduce:
1. Register rhel 8 client with satellite
2. yum -y install katello-host-tools-tracer


Actual results:
Failed with dependency issue

Problem: package katello-host-tools-tracer-3.4.2-2.el8sat.noarch requires python3-tracer, but none of the providers can be installed
  - conflicting requests
  - nothing provides python3-beautifulsoup4 needed by python3-tracer-0.7.1-1.el8sat.noarch
  - nothing provides python3-psutil needed by python3-tracer-0.7.1-1.el8sat.noarch
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)


Expected results:
Successful install of katello-host-tools-tracer.


Additional info:

Comment 3 Nikhil Kathole 2019-03-18 15:28:26 UTC
VERIFIED

Version tested:
Satellite 6.5 snap 20

# yum install katello-host-tools-tracer
Updating Subscription Management repositories.
sat6tool8                                                                                                         719  B/s | 2.1 kB     00:02    
Dependencies resolved.
==================================================================================================================================================
 Package                                 Arch            Version                         Repository                                          Size
==================================================================================================================================================
Installing:
 katello-host-tools-tracer               noarch          3.4.2-2.el8sat                  Default_Organization_Sat6Tools8_sat6tool8           21 k
Installing dependencies:
 python3-lxml                            x86_64          4.2.3-1.el8                     appstream                                          1.5 M
 python3-webencodings                    noarch          0.5.1-6.el8                     appstream                                           27 k
 python3-setuptools                      noarch          39.2.0-4.el8                    baseos                                             162 k
 python3-tracer                          noarch          0.7.1-2.el8sat                  Default_Organization_Sat6Tools8_sat6tool8          115 k
 katello-host-tools-fact-plugin          noarch          3.4.2-2.el8sat                  Default_Organization_Sat6Tools8_sat6tool8           18 k
 python3-future                          noarch          0.16.0-11.el8sat                Default_Organization_Sat6Tools8_sat6tool8          784 k
 python3-psutil                          x86_64          5.0.1-3.el8sat                  Default_Organization_Sat6Tools8_sat6tool8          289 k
 python3-beautifulsoup4                  noarch          4.6.3-2.el8sat                  Default_Organization_Sat6Tools8_sat6tool8          185 k
 tracer-common                           noarch          0.7.1-2.el8sat                  Default_Organization_Sat6Tools8_sat6tool8           31 k
 katello-host-tools                      noarch          3.4.2-2.el8sat                  Default_Organization_Sat6Tools8_sat6tool8           34 k
Installing weak dependencies:
 python3-html5lib                        noarch          1:0.999999999-6.el8             appstream                                          214 k

Transaction Summary
==================================================================================================================================================
Install  12 Packages

Total download size: 3.3 M
Installed size: 12 M
Is this ok [y/N]: y
Downloading Packages:
(1/12): python3-webencodings-0.5.1-6.el8.noarch.rpm                                                                11 kB/s |  27 kB     00:02    
(2/12): python3-html5lib-0.999999999-6.el8.noarch.rpm                                                              53 kB/s | 214 kB     00:04    
(3/12): python3-setuptools-39.2.0-4.el8.noarch.rpm                                                                 79 kB/s | 162 kB     00:02    
(4/12): katello-host-tools-fact-plugin-3.4.2-2.el8sat.noarch.rpm                                                  8.2 kB/s |  18 kB     00:02    
(5/12): python3-tracer-0.7.1-2.el8sat.noarch.rpm                                                                   38 kB/s | 115 kB     00:03    
(6/12): python3-lxml-4.2.3-1.el8.x86_64.rpm                                                                       174 kB/s | 1.5 MB     00:08    
(7/12): python3-psutil-5.0.1-3.el8sat.x86_64.rpm                                                                  121 kB/s | 289 kB     00:02    
(8/12): tracer-common-0.7.1-2.el8sat.noarch.rpm                                                                    37 kB/s |  31 kB     00:00    
(9/12): python3-future-0.16.0-11.el8sat.noarch.rpm                                                                174 kB/s | 784 kB     00:04    
(10/12): katello-host-tools-3.4.2-2.el8sat.noarch.rpm                                                              26 kB/s |  34 kB     00:01    
(11/12): katello-host-tools-tracer-3.4.2-2.el8sat.noarch.rpm                                                       32 kB/s |  21 kB     00:00    
(12/12): python3-beautifulsoup4-4.6.3-2.el8sat.noarch.rpm                                                          53 kB/s | 185 kB     00:03    
--------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                             276 kB/s | 3.3 MB     00:12     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                                          1/1 
  Installing       : tracer-common-0.7.1-2.el8sat.noarch                                                                                     1/12 
  Installing       : python3-psutil-5.0.1-3.el8sat.x86_64                                                                                    2/12 
  Installing       : python3-future-0.16.0-11.el8sat.noarch                                                                                  3/12 
  Installing       : katello-host-tools-fact-plugin-3.4.2-2.el8sat.noarch                                                                    4/12 
  Installing       : katello-host-tools-3.4.2-2.el8sat.noarch                                                                                5/12 
  Installing       : python3-setuptools-39.2.0-4.el8.noarch                                                                                  6/12 
  Installing       : python3-webencodings-0.5.1-6.el8.noarch                                                                                 7/12 
  Installing       : python3-html5lib-1:0.999999999-6.el8.noarch                                                                             8/12 
  Installing       : python3-beautifulsoup4-4.6.3-2.el8sat.noarch                                                                            9/12 
  Installing       : python3-lxml-4.2.3-1.el8.x86_64                                                                                        10/12 
  Installing       : python3-tracer-0.7.1-2.el8sat.noarch                                                                                   11/12 
  Installing       : katello-host-tools-tracer-3.4.2-2.el8sat.noarch                                                                        12/12 
  Running scriptlet: katello-host-tools-3.4.2-2.el8sat.noarch                                                                               12/12 
  Running scriptlet: katello-host-tools-tracer-3.4.2-2.el8sat.noarch                                                                        12/12 
  Verifying        : python3-html5lib-1:0.999999999-6.el8.noarch                                                                             1/12 
  Verifying        : python3-lxml-4.2.3-1.el8.x86_64                                                                                         2/12 
  Verifying        : python3-webencodings-0.5.1-6.el8.noarch                                                                                 3/12 
  Verifying        : python3-setuptools-39.2.0-4.el8.noarch                                                                                  4/12 
  Verifying        : python3-tracer-0.7.1-2.el8sat.noarch                                                                                    5/12 
  Verifying        : katello-host-tools-fact-plugin-3.4.2-2.el8sat.noarch                                                                    6/12 
  Verifying        : python3-future-0.16.0-11.el8sat.noarch                                                                                  7/12 
  Verifying        : python3-psutil-5.0.1-3.el8sat.x86_64                                                                                    8/12 
  Verifying        : python3-beautifulsoup4-4.6.3-2.el8sat.noarch                                                                            9/12 
  Verifying        : tracer-common-0.7.1-2.el8sat.noarch                                                                                    10/12 
  Verifying        : katello-host-tools-3.4.2-2.el8sat.noarch                                                                               11/12 
  Verifying        : katello-host-tools-tracer-3.4.2-2.el8sat.noarch                                                                        12/12 
Installed products updated.

Installed:
  katello-host-tools-tracer-3.4.2-2.el8sat.noarch        python3-html5lib-1:0.999999999-6.el8.noarch   python3-lxml-4.2.3-1.el8.x86_64           
  python3-webencodings-0.5.1-6.el8.noarch                python3-setuptools-39.2.0-4.el8.noarch        python3-tracer-0.7.1-2.el8sat.noarch      
  katello-host-tools-fact-plugin-3.4.2-2.el8sat.noarch   python3-future-0.16.0-11.el8sat.noarch        python3-psutil-5.0.1-3.el8sat.x86_64      
  python3-beautifulsoup4-4.6.3-2.el8sat.noarch           tracer-common-0.7.1-2.el8sat.noarch           katello-host-tools-3.4.2-2.el8sat.noarch  

Complete!

Comment 6 errata-xmlrpc 2019-05-14 12:40:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2019:1222


Note You need to log in before you can comment on or make changes to this bug.