Bug 168743 - Unable to build gnome-vfs-2.12.0
Unable to build gnome-vfs-2.12.0
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-vfs2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-19 18:13 EDT by Rodd Clarkson
Modified: 2013-03-05 22:44 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 16:09:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 315001 None None None Never

  None (edit)
Description Rodd Clarkson 2005-09-19 18:13:21 EDT
Description of problem:

In an attempt to try and figure out what recent updates have broken gnome-vfs2
(see but #16785) I tried to rebuild gnome-vfs (to see if timely changes to dbus
might be the cause).

Unfortunately gnome-vfs2 won't build.  It fails with the following output:

 gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I.. -I../imported/neon -pthread
-DORBIT2=1 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
-I/usr/include/libxml2 -I/usr/include/gconf/2 -I/usr/include/orbit-2.0 -pthread
-DORBIT2=1 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
-I/usr/include/gconf/2 -I/usr/include/orbit-2.0 -I/usr/include/howl-0.9.8
-D_FILE_OFFSET_BITS=64 -D_BSD_SOURCE -D_LARGEFILE64_SOURCE
-D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT -DSSH_PROGRAM=\"/usr/bin/ssh\"
-DG_DISABLE_DEPRECATED -DGNOME_VFS_PREFIX=\"/usr\"
-DGNOME_VFS_DATADIR=\"/usr/share\" -DGNOME_VFS_LIBDIR=\"/usr/lib\"
-DGNOME_VFS_SYSCONFDIR=\"/etc\" -DG_LOG_DOMAIN=\"gnome-vfs-modules\"
-I/usr/kerberos/include -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -m32 -march=i686 -mtune=pentium4
-fasynchronous-unwind-tables -c smb-method.c -MT smb-method.lo -MD -MP -MF
.deps/smb-method.TPlo  -fPIC -DPIC -o .libs/smb-method.o
smb-method.c: In function 'do_close':
smb-method.c:1489: error: 'struct _SMBCCTX' has no member named 'close'
make[2]: *** [smb-method.lo] Error 1
make[2]: Leaving directory `/home/rodd/rpmbuild/BUILD/gnome-vfs-2.12.0/modules'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/rodd/rpmbuild/BUILD/gnome-vfs-2.12.0'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.19398 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.19398 (%build)
[rodd@localhost ~]$



Version-Release number of selected component (if applicable):

gnome-vfs2-2.12.0-1
dbus-0.50-1
Comment 1 sangu 2005-09-22 04:28:39 EDT
This problem happens in samba-3.0.20.
See Also : http://bugzilla.gnome.org/show_bug.cgi?id=315001 .



Comment 2 Rodd Clarkson 2005-09-24 17:04:52 EDT
The bug you mention show that there is a fix for this.  Any chance of pulling
that  fix into fedora so that we can get gnome-vfs built and working again.
Comment 3 John (J5) Palmieri 2005-09-28 16:09:25 EDT
I added the patch and it compiled in Rawhide.

Note You need to log in before you can comment on or make changes to this bug.