Bug 168761 - kernel 2.6.13-1.1560_FC5 - strange "idr_remove" traceback
kernel 2.6.13-1.1560_FC5 - strange "idr_remove" traceback
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-20 01:46 EDT by Michal Jaegermann
Modified: 2015-01-04 17:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-06 00:20:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2005-09-20 01:46:06 EDT
Description of problem:

The following message from a kernel 2.6.13-1.1560_FC5 on x86_64 showed
up when I was shutting down an extra X-server:

idr_remove called for id=5 which is not allocated.

Call Trace:<ffffffff8020110b>{idr_remove+255} <ffffffff8024de9b>{release_dev+1920}
       <ffffffff8016a13e>{free_block+443} <ffffffff801673ca>{dbg_redzone1+28}
       <ffffffff80167e96>{cache_free_debugcheck+516}
<ffffffff801675b0>{poison_obj+49}
       <ffffffff8024dece>{tty_release+17} <ffffffff80186875>{__fput+188}
       <ffffffff80183f06>{filp_close+90}
<ffffffff801367c3>{put_files_struct+117}       <ffffffff8013781e>{do_exit+532}
<ffffffff80138305>{sys_exit_group+0}
       <ffffffff8010daec>{tracesys+209} 


Apart of this "which is not allocated" and a traceback so far this does
not seem to have any further consequences.  I also failed to reproduce
that.
Comment 1 Dave Jones 2005-10-06 02:48:15 EDT
repeatable with current rawhide ?
Comment 2 Michal Jaegermann 2005-10-06 11:46:21 EDT
> repeatable with current rawhide ?

Well, I got it with a relatively current one. :-)

As I wrote I could not reproduce that even with a setup where this showed up.
If this is some race then that I cannot repeat it does not mean that much.
Comment 3 Dave Jones 2006-03-06 00:20:44 EST
Ok, there's no other reports of this, and that code did change somewhat since
2.6.13, so I'm going to close this. Feel free to reopen/file a new bug if it
reoccurs.

Note You need to log in before you can comment on or make changes to this bug.