Bug 168765 - X fails to start with memory problems
X fails to start with memory problems
Status: CLOSED DUPLICATE of bug 168752
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-20 03:14 EDT by Knut-Håvard Aksnes
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-20 04:37:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log file from X server (41.68 KB, text/x-log)
2005-09-20 03:16 EDT, Knut-Håvard Aksnes
no flags Details
Output from /sbin/lspci -vvn (6.47 KB, application/octet-stream)
2005-09-20 03:17 EDT, Knut-Håvard Aksnes
no flags Details

  None (edit)
Description Knut-Håvard Aksnes 2005-09-20 03:14:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc3 Firefox/1.0.6

Description of problem:
X startup fails on FC4 after upgrading using yum.
The machine worked well with FC3 but a few days ago I uppgraded to FC4. The machine still worked well so I did a yum update. Yesterday I rebooted, after that X11 fails at startup with a garbled display.
Output from /sbin/lspci -vvn and the logfile /var/log/Xorg.0.log are attached
The problem is the same running under the kernels 2.6.11-1.1369_FC4 and 2.6.12-1.1447_FC4

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-37.FC4.48.1

How reproducible:
Always

Steps to Reproduce:
1. Booting the system 


Actual Results:  Garbled display

Expected Results:  Login window should be visible at the centre of my display

Additional info:

The system is practically useless as it stands (I can log into it using ssh) 
One of the problems being that yum/rpm lacks a revert to earlier version option.
rpm --oldpackage isn't safe for applications like X11 where config files might be converted during an upgrade.
Comment 1 Knut-Håvard Aksnes 2005-09-20 03:16:20 EDT
Created attachment 119013 [details]
Log file from X server
Comment 2 Knut-Håvard Aksnes 2005-09-20 03:17:36 EDT
Created attachment 119014 [details]
Output from /sbin/lspci -vvn
Comment 3 Mike A. Harris 2005-09-20 04:37:51 EDT

*** This bug has been marked as a duplicate of 168752 ***

Note You need to log in before you can comment on or make changes to this bug.