Bug 168769 - Python add-on libraries incompatible with python2.3 interpreter
Python add-on libraries incompatible with python2.3 interpreter
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mihai Ibanescu
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-20 04:49 EDT by Analabha Roy
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 11:20:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Analabha Roy 2005-09-20 04:49:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc3 Firefox/1.0.6

Description of problem:
NO dependency conflicts showing. everything installed from apt rpm repos for fc3. running any python program causes crash with tracebacks like:

ImportError: /usr/lib/python2.3/site-packages/<some library.so>: undefined symbol: PyUnicodeUCS4_<something>

 Looks like these add-on libraries are somehow incompatible with the python interpreter installed.
 Dunno how this happened.

 Note to developers: You have my full cooperation. If this is a packaging problem, please let me know what I can do to help fix it (hariseldon99@gmail.com). I really need python to be working.


Version-Release number of selected component (if applicable):
python-2.3.4-13.1

How reproducible:
Always

Steps to Reproduce:
1.Execute any python program (eg, Bram Cohen's bittorrent client)
2. It crashes with errors of the type mentioned above
3.
  

Actual Results:  crash:

Traceback (most recent call last):
  File "/usr/bin/bittorrent", line 32, in ?
    import gtk
  File "/usr/lib/python2.3/site-packages/PIL/__init__.py", line 33, in ?
    
ImportError: /usr/lib/python2.3/site-packages/gtk-2.0/gobject.so: undefined symbol: PyUnicodeUCS4_AsUnicode


Expected Results:  application should have started

Additional info:
Comment 1 Jeremy Katz 2005-09-20 17:43:36 EDT
This is actually something that we've fixed in FC4
Comment 2 Analabha Roy 2005-09-20 18:01:32 EDT
(In reply to comment #1)
> This is actually something that we've fixed in FC4

Erm, here's the wierd thing. There is a bug in fc4 installer that causes it to
crash whenever I try to install it. I tried the "garbage' fix in:

https://www.redhat.com/archives/fedora-list/2005-June/msg03392.html

 . It started the installer, but it crashed whenever I tried to upgrade.
Screenshots of tty's at the time of the crash are here:

http://www.ph.utexas.edu/~daneel/photoalbum/KIPIHTMLExport/mem1/index.html


 Is there any possibility that this can be fixed in fc3?


Comment 3 Mihai Ibanescu 2005-09-30 11:20:09 EDT
Very unlikely for this to be backported to fc3, mostly because it requires
significant packaging changes.

Note You need to log in before you can comment on or make changes to this bug.