Bug 1687740 - How to include a vendor plugin container image in RHOSP13
Summary: How to include a vendor plugin container image in RHOSP13
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation
Version: 14.0 (Rocky)
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ---
: 13.0 (Queens)
Assignee: Laura Marsh
QA Contact: RHOS Documentation Team
URL:
Whiteboard: docs-accepted
: 1740882 (view as bug list)
Depends On:
Blocks: 1730000 1730001 1740882 1818141
TreeView+ depends on / blocked
 
Reported: 2019-03-12 09:38 UTC by Keigo Noha
Modified: 2020-04-29 15:09 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1730000 1730001 1740882 (view as bug list)
Environment:
Last Closed: 2019-08-13 19:09:59 UTC
Target Upstream Version:
tshefi: automate_bug-


Attachments (Terms of Use)

Description Keigo Noha 2019-03-12 09:38:08 UTC
Description of problem:
How to include a vendor specific cinder volume container image in RHOSP14.
From RHOSP14, for container image, the guide explains to use '$ openstack tripleo container image prepare default \   --output-env-file containers-prepare-parameter.yaml'.

However, the method only describes for Red Hat shipped images.
In Cinder, users will need to use a vendor specific cinder volume container image for their storage.

Comment 1 Alan Bishop 2019-03-12 15:08:25 UTC
I looked over the current osp14 documentation. It looks like most of the details are there, but could the docs could be improved to specifically cover this use case (i.e. deploying a vendor plugin). The relevant sections are [1] and [2].

[1] https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/14/html/advanced_overcloud_customization/sect-containerized_services#container-image-preparation-parameters
[2] https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/14/html/advanced_overcloud_customization/sect-containerized_services#layering-image-preparation-entries

It looks like [2] provides the details, but the title "Layering image preparation entries" doesn't make this clear. It states, "The following example demonstrates two entries where the director uses the latest version of all images except for the nova-api image, which uses the version tagged with 14.0-44." This section could be enhanced with another example, stating something like:

"The following example demonstrates two entries where the director uses the latest version of all images except for the cinder-volume image, which uses a vendor plugin."

I don't know if any vendors have submitted plugins for OSP-14, but it would be great if we could test the procedure by attempting a deployment that includes the vendor's plugin.

Comment 2 Alan Bishop 2019-03-15 16:51:07 UTC
I tested my own suggestion in comment #1 and learned that it currently does not work. The reason is 3rd-party plugins are distributed in Red Hat's registry.connect.redhat.com container catalog, which requires authentication that is currently not supported by the director's "openstack tripleo container image prepare default" command. Until the director supports container registry authentication, it will be necessary to manually pull down the plugin. Here is an example using Dell EMC's cinder-volume plugin for OSP-14.

1. Log into the registry.connect.redhat.com catalog

% docker login registry.connect.redhat.com

2. Download the plugin

% docker pull registry.connect.redhat.com/dellemc/openstack-cinder-volume-dellemc-rhosp14

3. Tag and push the image to the local undercloud registry (substitute the proper undercloud IP address)

% docker tag registry.connect.redhat.com/dellemc/openstack-cinder-volume-dellemc-rhosp14 192.168.24.1:8787/dellemc/openstack-cinder-volume-dellemc-rhosp14
% docker push 192.168.24.1:8787/dellemc/openstack-cinder-volume-dellemc-rhosp14

4. Deploy the overcloud with an additional env file that contains the following:

parameter_defaults:
  DockerCinderVolumeImage: 192.168.24.1:8787/dellemc/openstack-cinder-volume-dellemc-rhosp14

Comment 9 Laura Marsh 2019-08-13 19:14:17 UTC
*** Bug 1740882 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.