Bug 1688068 - Proper error message needed for FUSE mount failure when /var is filled.
Summary: Proper error message needed for FUSE mount failure when /var is filled.
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: fuse
Version: mainline
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
Assignee: Amar Tumballi
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1685406
TreeView+ depends on / blocked
 
Reported: 2019-03-13 04:03 UTC by Amar Tumballi
Modified: 2019-03-29 07:25 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-29 07:25:36 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 22346 None Merged mount.glusterfs: change the error message 2019-03-29 07:25:35 UTC

Description Amar Tumballi 2019-03-13 04:03:59 UTC
This bug was initially created as a copy of Bug #1685406


Description of problem:
On a gluster client, if we try to mount volume when /var is filled completely FUSE mount fails with:
################################################################################
# mount.glusterfs my-node.redhat.com:/testvol_replicated/ bug/
ERROR: failed to create logfile "/var/log/glusterfs/bug-.log" (No space left on device)
ERROR: failed to open logfile /var/log/glusterfs/bug-.log
Mount failed. Please check the log file for more details.
################################################################################

Instead of which a proper error message should be displayed like:
################################################################################
# mount.glusterfs my-node.redhat.com:/testvol_replicated/ bug/
ERROR: failed to create logfile "/var/log/glusterfs/bug-.log" (No space left on device)
ERROR: failed to open logfile /var/log/glusterfs/bug-.log
Mount failed as no space left on device please free disk space. 
################################################################################
As the present error message is misleading.


How reproducible:
1/1

Steps to Reproduce:
1. Create one volume of any type and start it. 
2. On the client node fill /var/log using fallocate.
3. Try to mount the volume on the client.



--- Discussions in above bug ---

> > # mount.glusterfs dhcp35-137.lab.eng.blr.redhat.com:/testvol_replicated/ bug/
> > ERROR: failed to create logfile "/var/log/glusterfs/bug-.log" (No space left on device)
> 
> 
> Doesn't the above line capture the 'issue' at hand?


In that case I would not want the error message "Mount failed. Please check the log file for more details." to be displayed at all. Because it would create confusion for when read by the user, as log-file creation itself failed.

Comment 1 Worker Ant 2019-03-13 04:08:43 UTC
REVIEW: https://review.gluster.org/22346 (mount.glusterfs: change the error message) posted (#1) for review on master by Amar Tumballi

Comment 2 Worker Ant 2019-03-29 07:25:36 UTC
REVIEW: https://review.gluster.org/22346 (mount.glusterfs: change the error message) merged (#2) on master by Amar Tumballi


Note You need to log in before you can comment on or make changes to this bug.