Bug 1688082 - [ko] Hangul input does not commit in Terminal, Firefox urlbar, Libreoffice [NEEDINFO]
Summary: [ko] Hangul input does not commit in Terminal, Firefox urlbar, Libreoffice
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 30
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException AcceptedBlocker
Keywords: i18n, Regression, Reopened
Depends On:
Blocks: F30BetaFreezeException F30FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2019-03-13 05:20 UTC by sangu
Modified: 2019-03-28 17:41 UTC (History)
14 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-03-28 17:41:18 UTC
awilliam: needinfo? (sangu.fedora)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Gitlab GNOME/mutter/merge_requests/499 None None None 2019-03-25 09:20 UTC

Description sangu 2019-03-13 05:20:27 UTC
Description of problem:
Hangul input does not commit in gnome-terminal or libreoffice

Version-Release number of selected component (if applicable):
1.5.1-3.fc30.x86_64

How reproducible:
always

Steps to Reproduce:
1. gnome-terminal or libreoffice starts
2. input "r" "k" with ibug-hangul 
3.

Actual results:
(empty)

Expected results:
가

Additional info:

Comment 1 Jens Petersen 2019-03-13 07:20:27 UTC
I could reproduce in
Fedora-Workstation-Live-x86_64-30-20190312.n.0.iso

ibus-hangul has not changed in a while so moving to ibus first.

Comment 2 fujiwara 2019-03-13 07:35:14 UTC

*** This bug has been marked as a duplicate of bug 1684424 ***

Comment 3 fujiwara 2019-03-22 03:11:48 UTC
I think the fix of bug 1632981 was deleted in mutter 3.32.0.

https://src.fedoraproject.org/rpms/mutter/pull-request/13#request_diff

Fedora 29 mutter 3.30.2 includes that fix but Fedora 30 mutter 3.32.0 does not include it.

Comment 4 Jens Petersen 2019-03-22 05:04:08 UTC
This an approved F29FinalBlocker, so proposing also as a Final Blocker for F30.

Comment 5 sandeep shedmake 2019-03-22 05:53:10 UTC
Co-incidentally, Hangul input work (commit) with gedit-3.32-0-1.fc30.

Comment 6 Jens Petersen 2019-03-22 06:36:29 UTC
This only affect the application listed in the summary AFAIK.

Comment 7 Geoffrey Marr 2019-03-25 18:44:18 UTC
Discussed during the 2019-03-25 blocker review meeting: [1]

The decision to classify this bug as an "AcceptedBlocker" and an "AcceptedFreezeException" was made as having input methods not working in major applications is obviously a serious bug, and affects live image so cannot be fully fixed with an update. This is also accepted as a Final blocker on the same basis the equivalent F29 bug (#1632981) was accepted: it violates the "basic functionality test" criterion when affected input methods are used, certainly including Korean and likely also affecting some Chinese IMs.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2019-03-25/f30-blocker-review.2019-03-25-16.01.txt

Comment 8 Fedora Update System 2019-03-25 21:28:32 UTC
mutter-3.32.0-2.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-58e5fe7ef3

Comment 9 Adam Williamson 2019-03-26 15:16:34 UTC
Can you please test the updated mutter and confirm that it is fixed? Thanks!

Comment 10 Fedora Update System 2019-03-27 00:45:05 UTC
mutter-3.32.0-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-58e5fe7ef3

Comment 11 Jens Petersen 2019-03-28 08:29:03 UTC
This LGTM, thanks

I tested Fedora-Workstation-Live-x86_64-30_Beta-1.8.iso.

Comment 12 Adam Williamson 2019-03-28 14:08:55 UTC
Great, thank you.

Comment 13 Adam Williamson 2019-03-28 16:40:52 UTC
As we actually got this fixed for Beta, I'm dropping CommonBugs.

Comment 14 Fedora Update System 2019-03-28 17:41:18 UTC
mutter-3.32.0-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.