Bug 16881 - First packet send (first dns lookup) fails with on demand dialing
First packet send (first dns lookup) fails with on demand dialing
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: wvdial (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-24 11:24 EDT by Hans de Goede
Modified: 2007-04-18 12:28 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-02 10:33:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2000-08-24 11:24:35 EDT
Setup a pots ppp link with on demand dialing, do:
telnet <existing and resolving host>

And you get a:
hostname lookup failure

Response, notice the failure message instead of the "Unknown host" message
given when you try to telnet to an unknown host.

I tried doing "echo 1 > /proc/sys/net/ipv4/ip_dynaddr", before ifupping the
ppp interface as documented, but that doesn't help.

I tried this with:
-a ppp asigned DNS, but there were already other correct and public
available DNS entries in /etc/resolv.conf.
-the correct (normally ppp asigned DNS) in /etc/resolv.conf and PEERDNS
off.

Also see bug 16640 where this was first discussed.
Comment 1 Hans de Goede 2004-06-02 10:33:24 EDT
This bug is ancient and I don't have the setup to reproduce this
anymore what do we do?

Note You need to log in before you can comment on or make changes to this bug.