Bug 16881 - First packet send (first dns lookup) fails with on demand dialing
Summary: First packet send (first dns lookup) fails with on demand dialing
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: wvdial   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-24 15:24 UTC by Hans de Goede
Modified: 2007-04-18 16:28 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-02 14:33:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hans de Goede 2000-08-24 15:24:35 UTC
Setup a pots ppp link with on demand dialing, do:
telnet <existing and resolving host>

And you get a:
hostname lookup failure

Response, notice the failure message instead of the "Unknown host" message
given when you try to telnet to an unknown host.

I tried doing "echo 1 > /proc/sys/net/ipv4/ip_dynaddr", before ifupping the
ppp interface as documented, but that doesn't help.

I tried this with:
-a ppp asigned DNS, but there were already other correct and public
available DNS entries in /etc/resolv.conf.
-the correct (normally ppp asigned DNS) in /etc/resolv.conf and PEERDNS
off.

Also see bug 16640 where this was first discussed.

Comment 1 Hans de Goede 2004-06-02 14:33:24 UTC
This bug is ancient and I don't have the setup to reproduce this
anymore what do we do?



Note You need to log in before you can comment on or make changes to this bug.