Bug 1688154 - No module named 'pygraphviz.tests'
Summary: No module named 'pygraphviz.tests'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-pygraphviz
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zbigniew Jędrzejewski-Szmek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-13 09:55 UTC by Till Hofmann
Modified: 2019-03-23 02:56 UTC (History)
1 user (show)

Fixed In Version: python-pygraphviz-1.5-2.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-23 02:56:38 UTC


Attachments (Terms of Use)

Description Till Hofmann 2019-03-13 09:55:25 UTC
Description of problem:
It's impossible to use pygraphviz as importing fails with the following error:
ModuleNotFoundError: No module named 'pygraphviz.tests'

Version-Release number of selected component (if applicable):
1.5-1

How reproducible:
always

Steps to Reproduce:
1. Install pygraphviz: dnf install python3-pygraphviz
2. Load the module in a python shell: python3 -c "import pygraphviz"

Actual results:
$ python3 -c "import pygraphviz"
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib64/python3.7/site-packages/pygraphviz/__init__.py", line 70, in <module>
    from pygraphviz.tests.test import run as test
ModuleNotFoundError: No module named 'pygraphviz.tests'

Expected results:
No error.

Comment 1 Zbigniew Jędrzejewski-Szmek 2019-03-13 09:58:59 UTC
This is probably the same as #1677978.

Comment 2 Till Hofmann 2019-03-13 10:04:14 UTC
Oh yes it is, I somehow missed that (possibly due to the generic summary).

This also affects F29, #1677978 was only fixed in rawhide. Do you want me to re-open it?

Comment 3 Zbigniew Jędrzejewski-Szmek 2019-03-13 10:13:23 UTC
No need, it's building now:  https://koji.fedoraproject.org/koji/taskinfo?taskID=33450774.

Comment 4 Fedora Update System 2019-03-13 10:19:46 UTC
python-pygraphviz-1.5-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-738145710f

Comment 5 Fedora Update System 2019-03-14 18:51:29 UTC
python-pygraphviz-1.5-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-738145710f

Comment 6 Fedora Update System 2019-03-23 02:56:38 UTC
python-pygraphviz-1.5-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.