Bug 1688176 - decrease the minReadySeconds value in ds fluend
Summary: decrease the minReadySeconds value in ds fluend
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: Jeff Cantrill
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-13 10:34 UTC by Anping Li
Modified: 2019-06-04 10:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:45:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:45:54 UTC
Github openshift cluster-logging-operator pull 138 None None None 2019-03-28 15:28:56 UTC

Description Anping Li 2019-03-13 10:34:04 UTC
Description of problem:
The ds/fluentd update in rolling status. the minReadySeconds is 600, It will take long time for fluentd upgrade. 

It is better to decrease the minReadySeconds value and enable concurrent update  to accelerate the upgrade process. 


Version-Release number of selected component (if applicable):
v4.0

How reproducible:
Always

Steps to Reproduce:
1. update the fluentd images in clusterloging operator
2. Watch the fluentd pod status
3.

Actual results:
The fluend pod are started in rolling

Expected results:
The fluentd pod can be started in parallel.

Additional info:

Comment 4 errata-xmlrpc 2019-06-04 10:45:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.